C-Command Software Forum

Disabling SpamSieve With Airmail

I’m using Airmail so there are no rules. I’ve unchecked the SpamSieve box in Airmail. I also closed (and even “Force Quit”) SpamSieve but every time an email comes in via Airmail SpamSieve is open again. So it seems like it’s still operating even though I’ve unchecked it in the Airmail advanced settings.

How do I completely disable temporarily?

Are you sure this isn’t because you also have Apple Mail running? Otherwise, this sounds like a question for the Airmail developers, since they wrote the code for the “Enabled” box and to launch SpamSieve.

Yes, Mail is closed.

However, there should be a way to close or disable SpamSieve and not have it active while email is coming in regardless of weather Airmail’s checkbox is working or not.

The problem I’m seeing is that an email is getting sent back to spam over and over. I’ve “trained” it and as soon as it comes back in to Airmail it goes right back to the spam folder. I’ve also “marked as not junk” in Airmail. So now I can’t tell if the problem is Airmail or SpamSieve.

You could uncheck all the boxes in SpamSieve’s Filters and Training preferences.

Sounds like you need to check the log to see whether the training is taking place and whether SpamSieve is again predicting the message to be spam, or whether it’s going to the Spam mailbox for some other reason.