C-Command Software Forum

Entourage, IMAP, crash after reboot

Hello,

every time I’m starting up Entourage with SpamSieve after boot/reboot SpamSieve freeze if a new mail coming in. The only option is to kill the app. Sometimes Entourage is OK after this. Sometimes not.
After relaunch the application works OK.

I’m using IMAP and several POP accounts. I’ve tried many variations with rules with no effect. Sometimes the system freezes totally. I have reinstalled Entourage and SpamSieve - no effect. In former times with POP SpamSieve worked perfect. But not with IMAP.
On the IMAP I’m using many folders with subfolders.

It seems that the script is the devil. If I kill the script, there is the ability of no freeze. I’m using german and spanish system, Mac OS X 10.4.11

Could anyone help? Does anyone have an idea to solve this problem?

Thanks in advance
Kara

It would be helpful if you could open the Activity Monitor program and select SpamSieve in the list. When it freezes, choose Sample Process from the View menu. Then save the resulting data to a file and send it to me.

Your subject refers to a crash. Is it actually crashing (with the Mac OS X crash reporter visible afterwards) or did you simply mean that it’s freezing?

I’ve send you the data, but also Activity Monitor freezed when SpamSieve worked.

I think I have found the devil: I is a “move to” rule from local folder to the IMAP. After I deactivated it, it seems OK. I want to move all messages from POP accounts to the IMAP. Does anybody know an alternative for this rule?

Best
Kara

In the log that you sent me, SpamSieve is frozen while it’s waiting for the OS to read some information about a folder of sounds. You might want to check the various OS sound folders and also Entourage’s sound sets folder to see if anything looks out of the ordinary.

I think it would be fastest if you could set your POP server(s) to forward the messages, rather than using Entourage to do this.

Thank you a lot for this hint!! I didn’t change anything with this folder. But maybe there is something corrupted both on six Macs? I use only your script Change settings.

I think it would be fastest if you could set your POP server(s) to forward the messages, rather than using Entourage to do this.

I did this for the first time until the problems occured. You are right, this is the better option. I’m looking forward.

Best
Kara

I don’t know. It could just be that your drive was busy and that’s what SpamSieve was waiting for when you took that particular sample.

I have found another reason for the crashes: One of our providers locks folders automatically if subfolders stay in this folder; you can create a subfolder only with a slash (/) at the end of the name of the main folder.

I tested the option message list repair in the context menu of Entourage and it reported: messages in this folder are not readable. Is that the reason for SpamSieves crashes?

I deactivated all rules except these for SpamSieve. Every time after a reboot I start Entourage first, SpamSieve crashes. After I kill the app and it is launching again everything works fine.
For the first time the bar right below of Entourage shows that it is trying to read the folders. The bar is working all the time.

The locking of the main folder (shows a padlock) is a standard configuration of the provider. It seems that SpamSieve can not work with this restriction. This would be an argument too why all six Macs have the same problem. Am I right? What can I do?

Best
Kara

To be clear, you have not reported any crashes. A crash is when Mac OS X says that an application has unexpectedly quit. This is completely different from when an application freezes or stops responding.

This error could certainly cause problems with Entourage, but I don’t think it would affect SpamSieve.

Are you referring to locked folders on your Mac or locked folders on the mail server? Please post a screenshot so that I can see what you mean. Also, please send me additional sample logs from SpamSieve.

I mean freezes. Sorry for my bad english - I don’t know the accurate terms in english.

Are you referring to locked folders on your Mac or locked folders on the mail server? Please post a screenshot so that I can see what you mean. Also, please send me additional sample logs from SpamSieve.

I mean locked folders on the mail server. Please have a look to the picture.

Actually SpamSieve isn’t responding - says Activity Monitor. I will send you the logs.

Best
Kara

Once again it looks like SpamSieve was waiting on the OS to examine a folder of sounds. I don’t think this is related to the locked folders on your mail server. There may be some sort of disk or network contention though. Please try launching SpamSieve before launching Entourage (e.g. make SpamSieve a login item in System Preferences) and see whether that helps.