C-Command Software Forum

Error when capturing to Mail.app

When using the capture key in Mail.app, I’ve been regularly seeing the following error…

"The capture script for Mail reported an error:

Mail may be downloading from the server or moving messages between mailboxes. Please wait until it’s done or take it offline."

This has been intermittent, but for the past couple of days I’ve not been able to import at all. I’ve tried waiting, reassigning the capture key, different mailboxes, selecting only a few emails, but always see that error. Yesterday a restart seemed to work for a while, but today even that hasn’t helped.

Any thoughts on what’s going on or what I should try? It’s an IMAP account (Gmail) on 10.6.

Thanks.

There’s no way for EagleFiler to tell which items Mail is changing, so it will show the error if there’s any sign of activity. This ensures that EagleFiler is copying the data in a consistent state. All you should need to do is either (a) tell Mail not to check for new messages and wait for it to finish downloading the existing messages, or (b) take the account offline using the Mailbox menu.

I am experiencing the same problem. With me it is taking place all the time - just cannot capture an Apple Mail message using F1. I checked to see how often Mail checks for new messages, and it’s every 5 minutes, so there should certainly be moments when I should be able to do the capturing. There does not seem to be a problem with physically dragging a Mail message into an EF drop pad or into an EF folder in a library. I check to see that there is no activity in Mail when I try the F1 capture, but it always gives me the error message. I tried the same with Outlook for the Mac, and that seems to be working just fine.

There shouldn’t be any mystery here because EagleFiler is looking at Mail’s Activity window to see whether it’s busy. So you can open the Activity window yourself to see what Mail’s doing. And if you want to force it to stop, you can go to the Mailbox menu and take it offline.

Yes, that’s true because when you drag and drop an individual message Mail saves a fresh copy of it as a temporary file. It does not let you drag more than one message, though, which is what most people are trying to do.

Right. And it was much less frustrating once I realized that the Activity Window Michael refers to was via Window->Activity and not the little pane below the list of mailboxes. Lots more activity visible in the former!

Once that activity stops, imports work fine.