C-Command Software Forum

File Name Issue?

Working on a Word document with many iterations, I want to use save-as to make intermediate versions. Since I’m working out of EagleFiler, I want to save the new documents to the To-Import file for the library. However, I get error messages claiming that the file name is unacceptable. I thought for awhile that perhaps EF didn’t accept names like Filename.4.3.08.doc because of the periods, although that didn’t seem right. Nonetheless, I tried Filename_4_3_08 and that would seem to work, but not always. I now wonder whether the issue is more a matter of EF not accepting a save into To-Import if there already exists a file with a name “too close” to the new one?

Is there a restriction on either filename or similarities for such save-as operations into To-Import?

No, it’s a folder just like any other. It sounds like you’re running into an error from Word, not EagleFiler.

Saving Word Files into EF
With experimentation I reproduced part of the problem.

DESCRIPTION OF PROBLEM, PART ONE
o create a test library with two test folders
o at Finder level, move Word 2004 file into the To-Import folder
o make a change in the file, save (no problem)
o within EF, move that file to a folder within the library
o at Finder level, try to save the file after a minor change. No dice. Get error message

“This is not a valid file name. Try one or more of the following…Select a file from the list of files and folders.”

o Ok, that’s sensible. So, use the dialog box to navigate to the right folder (the one to which the file had been moved). This time, the message asks about replacing the existing file. Say Replace. However, the result is to get the same error message as above “This is not a valid file name…”

The altered file, however, has in fact replaced the previous one, even though there is feedback to the contrary. Function seems ok; error message is a fib.

DESCRIPTION OF PROBLEM, PART TWO.
This, I cannot reproduce easily. Let me merely say that in the course of doing things such as the above (saving variants to EF), at one point yesterday I got the scary error message (copied and pasted, with some changes; not literal):

“There is an unrecoverable disk error on file ****
The disk you are working on has a media problem that prevents word from useing it.
Try the following:
*Try formatting another disk
*Save the documents to another disk”

After musing about this, and surfing the web about the problem (which turned up complete red herrings, such as viruses and actual problems), I ignored the “problem” and went on.

Bottom Line: There seems to be a glitch, whether in Word, Finder, or EF, that need not cause trouble, but that is at least troublesome. And, in perhaps odd circumstances, it can generate an unusually scary error message.

All of the error messages that you mentioned are coming from Word. The error message about the filename seems to be misleading, because Word ordinarily does let you use periods in a filename. I don’t know exactly what’s going wrong, but it sounds like you aren’t using the “To Import” folder properly, and so Word is getting confused when the file is not where it expects.

The “To Import” folder is a drop box, a place to save documents so that EagleFiler will import them. Once you save a file there, EagleFiler will copy it into the library and delete it. Thus, you should not attempt to edit (or re-save) a file in the “To Import” folder, because it may not be there anymore. You should instead open the file that’s in the library.

What does it mean to make a change and save the file at the Finder level? The Finder does not edit files.

If you want me to look into this further, I would need a more complete list of steps. The above one omits everything to do with Word, and you haven’t said which version you’re using.

The periods are ok. I checked those out separately.

I understand. That’s what I meant by the “that’s reasonable.”

Sorry, I misspoke. I am in Office 2004, version 11.5.0. I believe you can reproduce this easily.

Save-as to the To-Import.

Then, in EF, move the file from Unfiled to an appropriate folder within the library.

Then, in Word, modify the file slightly. Try to just “save.” Not surprisingly, there is an error because Word’s prior knowledge is no longer correct. So, use the navigation feature to select the right folder. Try saving there. Here one gets the correct query “do you want to replace the existing file?” (paraphrased).

Click “replace.” Get another error message, even though in fact the file was replaced.

Subsequently, there is no problem. That is, if one ignores the error, all seems well. I have done successive edits, saved, and checked that the edits appear in the preview window after clicking the file in EF.

As mentioned earlier, I don’t know the circumstances that generated the even-worse error message.

Yes, I can reproduce that. It looks like a bug in Word. It seems like it does replace the file, but I think it would be easier (and it would avoid the error message) if you closed the file in Word and then double-clicked the file in EagleFiler to open it in Word from its new location.