C-Command Software Forum

I beg of you... add an option to have a default library!

Pretty please? I really need EagleFiler to be ready to go as soon as I click on it in the dock. As it currently stands I have to right-click the icon after the app has launched and click my library.

I only have one library! This is an unnecessary step for me, and it’s really annoying as I frequently quit my apps when I’m through with them.

Furthermore, not having a library basically makes EagleFiler incompatible with the Fujitsu ScanSnap line of scanners. I have a custom profile set up for EagleFiler, but whenever I scan it gives me an error saying no library is loaded. -__- Then I have to right-click the dock, load the library, and scan all over again. Crazy! The ScanSnaps are generally regarded as the highest quality on the market – EagleFiler really should support them!

I really hope the option for a default library is added soon. I ran a search on the forum before posting this thread and found similar requests from over 5 years ago. Yikes! I’d really love to feel warm & fuzzy that I won’t have to wait that long… I really don’t want to go back to using Yep due to all the bugs, but not having an option for default library is truly a dealbreaker for me.

(Also I’m aware of the option to “Remember open libraries between launches” in the Preferences pane; this option is currently broken and does absolutely nothing on my 2012 MacBook Pro running Mountain Lion)

I’m begging you!

That’s what the Remember open libraries between launches preference is for. You can also put an alias to your default library in the Startup Items folder to make EagleFiler open it even if it wasn’t open when you last quit EagleFiler.

No, it doesn’t. If you set the ScanSnap software to send the file to EagleFiler, it will import into the current library that’s open; this is useful when you have multiple libraries and don’t want to make multiple ScanSnap profiles. However, you can also set ScanSnap to “Scan to File” and pick a folder, e.g. the “To Import” folder of your default library. This will work whether or not EagleFiler or that library is open.

If you get into this situation, you don’t have to scan all over again. After opening the library, just click the Import button in the “No Library Is Open” window.

I’m also running a 2012 MacBook Pro with Mountain Lion, and that option is working fine. It’s been years since I’ve heard any reports of problems with that feature. Please follow these instructions to send some more information about the problem to technical support.

Yeah, but then the icon in the ScanSnap manager will be a folder instead of the EagleFiler icon. Maybe that’s not a big deal to some people but I’m kind of OCD about how my computer is arranged and that would really bother me. I use a Mac for a reason. :stuck_out_tongue:

I figured it out. I started using an app called “RedQuits” specifically for EagleFiler because by default it does the annoying thing where clicking the red X doesn’t close the program. You see, I use an AppleScript to mount an encrypted sparsebundle (which contains my EagleFiler library) and then launch EagleFiler. I then use an app called “Do Something When” to automatically unmount the sparsebundle when I quit EagleFiler. With this system my sparsebundle mounts and unmounts automatically (assuming the password is saved in keychain) and my data is encrypted with no real work being done by me. This gives me more of a warm & fuzzy when using services like CrashPlan and leaves my workflow completely uninterrupted.

Anyway, I’m used to Yep which quits completely when you click the red X. EagleFiler does not, so my sparsebundle was staying mounted indefinitely, which I try to avoid for backup purposes. Unfortunately, when I quit EagleFiler with “RedQuits” it doesn’t remember the library when I launch again. Considering that quitting with “RedQuits” is the only way I close the app, this is very inconvenient to me. I really hope something can be done with this so that EagleFiler can fulfill me needs… Yep is just so damn buggy and they never update it.

Unfortunately, it looks like ScanSnap doesn’t display custom folder icons. OK, then another option would be to save the Import From Scanner script as a droplet and give it EagleFiler’s icon. You could also add a line to the script that ensures that your default library is open. For example:

open POSIX file "/Users/mjt/Desktop/EagleFilerTest/EagleFilerTest.eflibrary"

I’m not sure that a script is really necessary here. If you make an alias to the .eflibrary file, the OS should remember which sparsebundle it came from.

EagleFiler does have the Close & Lock feature, but I agree that it would be good to make this more automatic.

Have you tried putting an alias to your library in EagleFiler’s Startup Items folder? Then it will always open the library, even if it had been closed before quitting.

I tried everything… no dice. Not when EagleFiler is closed using “RedQuits.” With normal File > Quit everything works fine, but that’s an extra step that I really don’t want to deal with. I’m not sure what “RedQuits” does differently but apparently EagleFiler takes issue with it. With the droplet added to ScanSnap Manager, it seems to open a new library with the scanned document in it (even with the extra line of code added to the script). With the alias solution it does in fact open my library… but it also opens like 3 other windows with blank libraries. Heh.

To be honest I think I’m done troubleshooting here, I absolutely loathe troubleshooting and messing with scripts and settings and whatever else. At this point I guess I’m posting just to request that the option to actually quit the program when clicking the red X be made available. Maybe as something you could toggle in settings… that seems like it should be pretty easy to implement. If I could drop the “RedQuits” app everything would be gravy. To be honest I’ve never understood why some apps don’t quit with the X… the yellow minimize button is there for a reason, if that’s what I want to do I’ll use that. :wink:

What do you mean by a “new library"? EagleFiler only creates new libraries when you specifically tell it to (via the File > New dialog).

That’s very strange. What are the titles of the other windows? Do you see anything in the log?

I understand that troubleshooting isn’t fun, but there’s a reason that the Startup Items feature works on other Macs but not on yours. There’s either a bug in EagleFiler (in which case I would like to fix it, so everyone gets the fix) or there’s a problem specific to your Mac (in which case it may be causing other issues for you). So I think it’s better to troubleshoot than to layer on additional preferences and utilities while ignoring the source of the problem.

I’ll consider that for a future version. Thanks.