C-Command Software Forum

IMAP - Moving a good message back to inbox

Recently, incorrectly indentified emails in my SPAM mail box in Apple Mail, are sluggishly moving back to the Inbox when trained as good.

Some times the move after a few seconds, sometimes not at all. Other times they move fine.

Any one seeing this behavior or have any ideas to share?

I am using a MacBook and 10.4.8. Also, I have MailTags, Mail.appetizer and DayLite DMI bundles installed.

TIA

Steve

I haven’t heard of that happening before. First I would try temporarily uninstalling the other bundles to see if that makes a difference.

You could also try using the Activity Monitor program to measure what’s going on during the move. Select the messages in Mail. Open Activity Monitor and select Mail in the list. Choose Sample Process from the View menu, then quickly switch to Mail and press Command-Control-G. Then switch back to Activity Monitor to see what it recorded during that time. Perhaps it will be evident from the window what it was doing, or you can save the sample to a file and send it to me.

“Trained as Good” messages not moved back to IMAP INBOX
I’m seeing the same problem here…

I have four IMAP mail accounts, each with its own spam folder. To distinguish between these folders in pop-up menus each includes the account name, such as “Spam: accountname”, and I have four separate rules (one per account) to move spammy messages into that account’s folder.

The messages are put into the folders OK. However when a false positive happens and I use the “Spam Sieve - Train as Good” menu item the message does NOT get moved back into that account’s INBOX; instead it remains in the spam folder. This is, of course, a pain.

I’ve used the “SpamSieve - Change Settings” menu item to ensure messages trained as good should be moved.

Is it because I’m using a non-standard name for the spam folder: “Spam: accountname” instead of “Spam”? Or because I have multiple IMAP accounts with separate spam folders? Or something else?

Yes. SpamSieve will only move the messages out of folders that it thinks are the spam folder. At present, in order for SpamSieve to think it’s the same folder, the name must be “Spam” or “Deleted Messages”, or start with “Junk”, or be the name that you chose in “SpamSieve - Change Settings”.

Same here but one regular Spam folder and not even IMAP.
Hello,

I have the exact same problem here, except that I have a regular Spam folder called Spam. This is the only folder SpamSieve puts spam into. I have a message (4.8MB in size) that was a false positive and the Train as Good command seems to do nothing at all except for some short rattle on the HD. The message remains in the Spam folder and stays coloured blueish gray.
I could of course move it back manually, but this would not get rid of the colouring.

What could cause that? The larger size?

Regards,

Gabriel

Which version of Mac OS X do you have? Please download the attached file, expand the Zip archive, and open the script in Script Editor. Switch to Mail and select the good message in question. Then switch to Script Editor and click the Run button. How long does it run for? Does it report an error?

Also, if you choose Open Log from SpamSieve’s Filter menu, and then do “Train as Good,” do you see a “Trained: Good (Manual)” entry for that message at the bottom of the console.log window?

Script works OK
Hello,

I have run the script on my renegade message and it went back into the Inbox just as it should and was decoloured just as expexted. No error messages.

I’m using Mac OS X 10.4.8 and Apple Mail.

Log
I checked the SpamSieve log and although there is a lot of records for previous sessions, I don’t seem to find any entry regarding that mail message, like the many times I pressed Train as Good would not end up being logged…
Hope this helps.

Could there be anything special in the message that causes the problem? This message has picture attachments and is like 5MB in size.

I suppose there could be something different about that message, although I’ve trained SpamSieve with many messages of that size before. I’d like to try it on my Mac to see if I can find where the problem is. Please try to find the mailbox folder that contains that message. It will be somewhere like:

~/Library/Mail/Mailboxes/Spam.mbox

Control-click on the .mbox and choose Create Archive, and then e-mail the Zip file to me at spamsieve@c-command.com.

I am unable to reproduce the misbehaviour :frowning: I have put that message back in the Spam folder, pressed Train as Good normally and it worked this time.
Next time I have another one like this, I’ll send it right away. OK?

My problem is WHICH Inbox the message is returned to!
I have multiple IMAP accounts set up in Apple Mail (10.4.8, etc).

I created one spam folder as specified in the setup instructions.

When I browse the spam folder, and mark a message “Train as Good” it returns it to the Inbox of the first account listed in my email account list (not necessarily the account the email was addressed to originally).

Would creating separate spam folders for each account solve this?

Thanks, what a terrific program so far!!!

Doug

No. The issue is that Mail doesn’t remember which account the messages came from, so SpamSieve has to guess based on the To address in the message and the addresses for your accounts. Often, there isn’t enough information to tell. If SpamSieve doesn’t find a match, it just uses the first account. You can re-order the accounts in Mail’s preferences to change which one this is.

Understood. Is there anything I can do (or settings I can modify) to “help” SpamSieve guess correctly when returning false positives to the correct account?

At present, you can change the default account, but there’s no way to improve the guessing except to try to make sure the e-mail you receive is addressed to the address specified in Mail’s account preferences.

Thanks! Well, the good news is that SpamSieve appears to have very few false positives after training, (which is excellent!) so this is not a huge problem. Still it would be nice for a solution someday, but will certainly not keep me from using the program in the meantime…