C-Command Software Forum

Import from Postbox fails 9 times of 10

Hi,

I’m trying to archive mail from Postbox into EF. I’m following these instructions, dragging the IMAP mailboxes from the Finder into Eaglefiler. EF accepts the file and starts the import. But most of the time, say 90 %, the result is not a new mailbox in my library, but just a single file containing all mails in the folder.

Am I doing something wrong or are the mailbox files corrupt in some way?

Best regards,
Anders

Which version of Postbox are you using? Would it be possible for you to send one of the problem mailboxes to me via e-mail?

I’m using 3.0.3. A mailbox is sent via email.

/Anders

Thanks. The mailbox that you sent is not a valid mbox file. The first line of each message should start with “From ”, but that line is missing. I’m not sure what’s causing that, as I just created a new profile with Postbox 3.0.3, and it seems to be saving the messages correctly. You might want to instead import individual messages using Save As. Or perhaps it would help to ask Postbox to copy the messages to a new, non-IMAP, mailbox.

Strange. Since some of the other folders were imported correct. From the same Postbox, with mail kept in folders on the same server.

Since I have a couple of thousand mails in these folders, importing them one by one is not an option. I’ll get them via Mail.app instead.

But first I’ll try a thing or two with Postbox.

After I made the successful imports earlier today, I emptied the folders. Now, I copied a few from one of the problematic folders to one of them which succeeded. And tried to import using that mailbox file instead. And it worked. Strange.