C-Command Software Forum

'Improve sound quality by disabling audio input' when device reconnects by itself?

Hi,

Currently with my Sennheiser Momentum True Wireless earphones, I like to just put them in my charging case to disconnect, rather than manually disconnecting from my mac. This means that they automatically reconnect to my mac when I remove them from the case.

I was hoping that Toothfairy would help my earphones to switch to AAC when they connect, but it seems that the ‘Improve sound quality by disabling audio input’ only works when using Toothfairy to manually reconnect.

It’s not the end of the world, because I can just disconnect and reconnect using Toothfairy when I take them out of the case, and it’s still saving me some effort, but it would be really cool if that wasn’t necessary.

Is this expected behaviour, and would it be possible to request this as a feature?

If it’s not technically feasible, then I understand.

Thanks!

That’s correct. I plan to investigate whether a future version of ToothFairy can fix the codec when the device connects via other means.

1 Like

Great, thanks for the confirmation of expected behaviour, will keep an eye on the release notes!

1 Like

Oh, so that’s what’s happening! I thought something was wrong with tooth fairy, but apparently the problem is when I turn on my Bluetooth headphones, macOS is reconnecting with both input and output :frowning:

Anything you could do about this would be greatly appreciated :slight_smile:

1 Like