C-Command Software Forum

Mail does not load spamsieve when launched after upgrade

Ok upgraded to leopard, and the only thing stopping spamsieve is that spamsive is not loading when mail does? anyone got a simple (or not) solution to what is not loading it. (i did re install spamsieve after upgrade and the menu items are there. If i select an email and say its good or bad it loads but just launching mail the first time during the day , all mail goes in the main inbox due to no spamsieve ;(

any ideas would be appreciated!!!

cosmic

Are you saying that Mail is uninstalling the SpamSieve plug-in the first time you launch it each day? And then you re-install the plug-in and it works? A couple other people (literally) have reported something like this, but we don’t yet know what’s causing it. There may be something overwriting Mail’s preferences file.

Just out of curiosity, do you have any other Mail plug-ins installed? Are you using .Mac syncing?

Same problem
I got the same problem, SpamSieve does not launch and I have re-installed the plug-in several times nothing happens.
And I have no other plugins installed and not using .Mac

I’m not clear on what is the “same” about your problem. Are you aware that SpamSieve isn’t supposed to launch when Mail launches only when there are new messages to filter? Do you see the SpamSieve commands in Mail’s Message menu? Does SpamSieve launch if you train a message as good or as spam? Is your SpamSieve rule at the top of the list in Mail? Is it set to apply to “Every message”?

When SpamSieve doesn’t launch, do you see any error messages in Console?

‘same problem’
Hi Michael,

I also have the ‘same’ problem - let me explain.

While using Tiger, if I launched Mail for the first time (say, after restarting the computer), then SpamSieve would spontaneously launch.

I’ve done a complete fresh install of Leopard, and consequently added all of my applications (not an upgrade in any way), and now when I launch Mail, SpamSieve doesn’t launch like it did before.

My partner’s Leopard install does launch SpamSieve like it used to under Tiger (when Mail is opened), but mine doesn’t (although his install was an ‘archive and install’ of Leopard) - I’ve also tried re-installing the SpamSieve plugins into Mail.

Certainly if I do “train as Good” or otherwise use a SpamSieve command in Mail, then SpamSieve will then launch.

The unfortunate side-effect of this is that because SpamSieve isn’t launching with Mail, all of my emails are classified as spam by the SpamSieve Rule.

While it’s easy to say “just launch SpamSieve before you launch Mail”, the fact is that I’m totally used to the process being automatic, and I haven’t yet “remembered” that I have to, until it’s too late - so I’m constantly re-training everything as ‘good’, which is somewhat annoying!

It seems, by your responses to earlier posts, that you didn’t intend that sort of spontaneous launch?

I dont have SpamSieve rule at the top of the list in Mail.
After installing Leopard it simply does not work?
I can however see the SpamSieve commands in Mail’s Message menu, but if I try to use the commands with my keyboard, nothing happens, but if I use the menu and start with marking a mail as good, then SpamSieve starts!?
Confusing I really don´t get it…?

That’s normal, if when Mail launches it connects to the mail server and finds new messages that need to be filtered.

What happens if you select a message and choose Message > Apply Rules, making sure that the SpamSieve rule is at the top of the list and is set to apply to Every Message?

(The code for launching SpamSieve when you apply the rule is exactly the same as for launching it when training from the menu.)

Are you sure it’s the SpamSieve rule doing that? The way the plug-in is coded, the rule first checks to see whether SpamSieve is running. If it’s not, it tries to launch SpamSieve. If it can’t launch SpamSieve, it reports an error (via an alert in Mail) and assumes the message is good. If it does launch SpamSieve but for some reason cannot communicate with SpamSieve, it also assumes the message is good. So, based on your description, it sounds to me like the SpamSieve rule isn’t even being applied.

Have you checked the Console for error messages?

Please put it there so that we can be sure that Mail will use it.

Which keys are you pressing? The keyboard shortcuts are Command-Control-S and Command-Control-G.

“Please put it there so that we can be sure that Mail will use it.”
Sorry, but how do I do that?

Choose Preferences from the Mail menu, then click on Rules. And then just drag and drop the SpamSieve rule to the top of the list.

The only rule in Pref/Rules is “News from Apple”.
But where can I find the SpamSieve rule?

If you don’t have one, you need to make one. Without a SpamSieve rule, SpamSieve will not auto-launch or filter any of your messages.

Great! Now it works like before, or better…
Thanks for accurate and fast support!
Once you have started with SpamSieve you don’t want to loose it.

Regards, Stefan