C-Command Software Forum

On My Mac -

I can not get SS to STOP creating a local folder ON MY MAC, I have trained it several times and have deleted and reinstalled the only ONE rule to put all spam on an IMAP server folder. When I flag something as spam it gets moved to the Local folder. If I delete it it just re-spawns.

It’s normal for SpamSieve to move trained spam messages to a mailbox on your Mac. The idea here is that it’s less efficient and will count towards your server quota to store spam on the server.

If you prefer to always use a server-side Spam mailbox, please see Using a Spam Mailbox on the Server.

For the past several years, I have had the following setup, and it has been working flawlessly and I assuming that Mountain Lion / Mail App / iCloud preference sharing has some how altered how things mesh together.

  1. iMac setup with SS configured working
  2. MacBook setup with SS configured working
  3. Each with the SpamSieve Rule.
  4. An IMAP email account spam@mydomain.com with an server side folder called ServerSpam
  5. SS on both computers are trained to use Server Folder and rules both target the ServerSpam folder
  6. I have about 8 email accounts I am monitoring

Over the past few months the Mail app will forget where the folder is in the RULE or the RULE will be disabled on either the iMac or Macbook

Both machines will create the ON MY MAC with the ServerSpam folder - and I will find stuff in there.

The reason I want ALL spam to goto ONE folder regardless of account is so that I can monitor important false positives when checking from my iPhone. Other wise I would have to navigate to each mail account’s spam folder - and that is tedious on the iPhone. Or may miss important stuff because its local to a machine.

Typically my iMac is the primary and always ON being the gatekeeper with SS but with out it running on the MacBook I still get tons of spam.

This is not related to SpamSieve. It may be caused by a problem with Mail or your hard drive.

You need to use the Change Settings command to tell SpamSieve that you want trained spam messages to go to the server. SpamSieve will always move trained spam messages to a mailbox on the same server. If there isn’t a spam mailbox on that server, it will look for one on the server of the first account. So you may need to drag your account to the top of the list.

This part is entirely controlled by the SpamSieve rule in Mail’s preferences.

This sort of setup can be problematic. Please see Using SpamSieve With Multiple Macs.

Thanks, will have to review all the settings again.

Currently only on my MacBook as the iMac is at Apple getting a new 1TB HD (replacement) so only one mac is operating at the moment.

Will let you know if I can get it behaving as it usually does.

Keep up the fine work!