Spam Getting Through iCloud Junk Filter to Apple Mail Inbox

Michael- I am having the exact same issue. I have created the AppleScript you suggested in my other post- but I 100% concur with OP. Something HAS CHANGED. I now get Junk over and over again and have to manually delete it- every single day iCloud has dozens of messages either in my Inbox or in my Junk. I used to be able to select a group of messages, apply a Spamsieve rule, and everything would be processed like magic. Now, no more.

I understand that Apple Mail has changed- but please note that the new version of Spamsieve does not address this.

Please see this thread- any suggestions you might have would be very appreciated.

The original poster says that SpamSieve is correctly moving the spam messages to Junk but that he is receiving more spam messages than before. Is this the exact same issue you are seeing? It seems like no, because you say that you’re getting lots of messages in the Inbox.

It should never have been necessary to manually apply SpamSieve because it should have been automatically filtering the new messages. You would only need to do that if there were a setup problem or if the messages were marked as read before they got to your Mac so that Mail didn’t see them as new.

If you want to manually apply SpamSieve you can still do so using the Filter Messages command.

This thread is about people either being sent more spam messages or Apple’s server filter letting more of them through. Most of the comments are a year old. I don’t see this as being related to Mail or SpamSieve.

If you are repeatedly getting spam messages in the Inbox, the first thing to do is check the log to see whether SpamSieve had predicted them to be good or spam or not at all. That will reveal whether there’s a setup problem or a filtering problem on your Mac.

Appreciate the help- really trying to fix this.

If you look at the Apple forum post there are recent postings that echo my issue- the volume of Apple SPAM has skyrocketed. I’m sure there is something wrong with my settings (though I have tried very hard to follow your help).

An example- this message came in today. It’s a “1”- clearly SPAM- but there is an AllowList rule that enables it- I did not create that Allowlist rule. Is there any way to stop this? Otherwise I have to go in manually and delete those rules.

There is no connection between your settings and the volume of spam. Your SpamSieve settings do not affect the volume of spam, just which mailbox the spam messages are filed into. Apple’s server filter does affect the volume of spam, but there are no settings to control it. So I really see no relevance to the Apple forum post. Yes, at any given time some people are sent more spam, and you can find some of these people talking about it, but this is not related to anything that you did, and there’s nothing that you can do to change it.

The problem here is that you had received previous spam messages from that sender in your inbox and not trained them as spam, so SpamSieve continued to think the sender was good. It’s really important to correct all the mistakes. Otherwise you are in effect telling SpamSieve that you want these messages in your inbox.

That’s a bad idea, as described under Spammy Allowlist Rules. It’s better to train the message as spam and let SpamSieve manage the allowlist.

You should go through the Log window and train any spam messages that say Predicted: Good with a green circle to undo the damage caused by not correcting the mistakes.

Yes, understood about volume of Spam from iCloud and why that is a tangent- I state that to underscore the direness of this situation and why I am trying to fix it.

Let me state clearly- my Spam filtering has fundamentally changed. I have used your product for years btw- not a noob.

Here’s an example- there are 3 examples in the Log from one message- for some reason the AllowList rule is being AUTOCREATED without my intervention. I am not training it as Good- in fact as I train messaged as Spam it does not seem to impact the future of those messages.

Why would this happen? 3 entries in the Log- same time. It landed in my Inbox. I trained it as spam. Suddenly there is an Allowlist rule that treats it as Good. I did nothing to cause that- why are these Allowlist rules being created? Also, if it is in the Corpus- how is it possible that hundreds of these messages were treated as Good?

So the issue is that you are getting some percentage of spams left in your inbox, and this is extra dire because the overall spam volume has increased, too? If so, this is pretty much the opposite of what the original poster was writing about.

Did you stop training the mistakes or have you been leaving them uncorrected all along?

This is a normal interaction between the Auto-train as needed and Train SpamSieve allowlist features. They have worked this way for many years. The idea is to prevent good messages from going to Junk by recognizing (automatically, even if you don’t train them) senders (or in this case mailing lists) who have previously sent you good messages. If a message turns out to be spam, when you train it as spam SpamSieve will disable the allowlist rule.

Are you saying that you received a later message from this same sender that was classified as good because of the same allowlist rule? If so, that sounds like something is wrong. If not, what makes you say that training the message didn’t do anything?

Your first example showed multiple messages with the same sender from previous days not trained as spam.

In this example, I only see one message. It looks like it was processed by SpamSieve twice, once when SpamSieve found it in the inbox and once perhaps due to an AppleScript that’s not built into SpamSieve.

If you trained the message as spam, the allowlist rule will be disabled, so it won’t cause any problems.

I don’t know which messages you’re referring to here. Are you saying that there are hundreds of messages from the same sender?