C-Command Software Forum

Spam not being cleared after wake from sleep

Hi,

I’m getting really frustrated and need some help!

Basically SS is not clearing spam when the iMac wakes from a period of sleep. The messages are just sitting in the inbox. When its awake it clears new messages, just not those that arrived during the sleep period.

Any ideas? using Lion 10.7.2, SS 2.8.7 and imap

Thanks

M

Are the uncleared messages marked as read or unread?

as marked as read

This probably means that you read them on some other device, such as an iPhone. So the issue may not have anything to do with the Mac being asleep. Mail does not apply its rules to messages that have been marked as read. It treats those messages as not new.

Thats really odd, you are right, they appear as read. But we are not reading them. We only use an iPhone to access the mail as well and do not read the messages. Any idea what might be happening?

Possibly another Mac, or a rule on your mail server, or someone reading your mail without your knowledge.

Have you tested this with the Mac going to sleep but not using the iPhone Mail app at all?

Also, please check these two folders:

/Users/<username>/Library/Mail/Bundles
/Library/Mail/Bundles

Are there any .mailbundle files there besides SpamSieve?

Thanks for your pointers Michael, they were really useful. They gave me enough guidance to know where to go looking and I have now finally solved the issue!

It turned out my missus had a gmail account that was accessing her mail server by POP3 (the timed mail check service in the settings>accounts). When it did this the mail turned to read on IMAP (to the mac and iPhone). I deleted this link to the mail server and now the mail drops in to the inbox and remains in an unread state - and spamsieve of course can work. So no more spam - thank goodness.

Interestingly the mail server company she uses were of no use when I called them, they just offered a $100 per year server side solution - so no thanks.

Glad you figured it out! I was aware of this Gmail feature but didn’t know that it marked the messages as read, so this is good to keep in mind if other people encounter this problem.