C-Command Software Forum

SpamSieve 2.9.11

The following was posted on the SpamSieve blog:

Version 2.9.11 of SpamSieve is now available. This is a free update that includes the following changes:

  • Works with the Mail Update for Mavericks 1.0.
  • Added a workaround for some rare cases where SpamSieve’s commands were not showing in Apple Mail’s Message
    menu. - Updated the Apple Mail - Discard Spam script.
  • Added some defensive coding to protect against a bug in _NSDispatchData that could cause a crash on Mavericks.
  • Made various updates and improvements to the manual.

SpamSieve 2.9.11 works with Mac OS X 10.5 through 10.9 and requires an e-mail client. Older versions are available for older operating systems. For information about previous releases of SpamSieve, please see the version history.

After earlier thinking that the new version of SS was flawed, I discovered that I hadn’t installed the Apple plug-in from the SpamSieve drop-down menu. Naughty boy! Users must remember to do this for whatever client they’re using. Ironically, because I did not, my password reminder from SS ended up in my spam folder. That was a giveaway! Thanks, Michael, for staying on top of the changes.

Usually this is not necessary. If you update SpamSieve before updating Mac OS X, SpamSieve will auto-update the plug-in. It will also do this if it detects that the plug-in has been disabled by an OS update. However, there are some cases where SpamSieve is not able to detect that it’s been disabled, and that’s when you need to reinstall the plug-in manually.