SpamSieve not showing up in menu bar

SpamSieve shows up momentarily in menu bar when in SpamSieve app, but it goes away. This occurred in Ventura and still does in Sonoma. Updated SpamSieve yesterday in Monterey and just updated to Sonoma and still not working.

I do have the app Hidden Bar since I’m on a 13 MBA. Maybe some interaction with Hidden Bar. I’ll try rebooting without Hidden Bar launching. But will have to post this first.

SpamSieve does show in menubar on my 27" monitor powered by a mini. Still at Ventura.

The amount of free menu bar space (where icons can go) changes depending on which app you’re in. Which app is it not working in, and does that app have menus that take up more or less space than SpamSieve’s menus?

And, yes, it would be good to test without Hidden Bar.

Rebooted. Shows up in menu bar in apps with few menu bar items (iPhone apps which don’t have a menu bar, so only defaults showing.

But in macOS apps with for example nine menu items like Safari which I’m in now, the SpamSieve menu bar item isn’t showing. Presumably because there isn’t room for it (OK I have too many menu bar items—I can see 15.

Menu bar in Finder with Hidden Bar:

Menu bar in Mail with Hidden Bar (screenshot):

OK, I found a work around. Hidden Bar has an option to move the menu bar items around. So now I see SpamSieve. But I really only want SpamSieve in Mail. And although I haven’t read all the docs yet, it appears that this is the only way to “Train…” Spam Sieve. I think this used to show up under Messages in Mail.

PS. I hadn’t seen response when I wrote this.

You can hold down the Command key to rearrange the icons, even without Hidden Bar.

The icon is not essential, as you can also train SpamSieve from the Dock menu or by using the keyboard shortcuts:

Apps are no longer allowed to add items to the Message menu in Sonoma.

1 Like

So the keyboard shortcuts work even if not showing. If so that’s great. (SpamSieve is working too well and I don’t have anything to test!)

Should have known the moving of icons was possible, thanks for the reminder.

Thanks for responding so quickly. I would think you’d be inundated with a new release.


Indeed, it’s keeping me really busy.

After upgrading to Sonoma 14.0, I have a problem I cannot resolve. I cannot find or enable the SpamSieve Menu Bar Icon.

Thanks in advance for any advice or help.

What does your menu bar look like? Is there empty space where the SpamSieve icon could go?

There are some changes in SpamSieve 3.0.1b2 to help detect where the menu bar icon is if you can’t find it. Please click to enable/disable some extra diagnostics. After you’ve updated and enabled the diagnostics, if the problem happens again, please send in a diagnostic report.

It looks like this:

It seems like there’s enough space there, unless you are on a MacBook that has a camera housing (notch) right where that blank space is. I wonder if you have a third-party menu bar management utility installed that’s interfering. If that’s not it, please try to gather the diagnostics that I suggested in the previous post.

It is a Macbook Pro, but I don’t have any third-party menu bar utilities.

Is it an M1 or M2 MacBook Pro? I believe those all have a camera housing that covers the middle of the menu bar near where you have 1Password. So there may not actually be space available even though it looks like there is.

You could try removing the battery, sound, or Wi-Fi menu bar icon, as those are all available in Control Center, anyway. Or, even if you only remove some icons temporarily, that might be enough so that you can see the SpamSieve icon and Command-drag it more to the right so that it stays visible.

M1 and yes there’s the camera housing. That’s not it though. I removed some ot the other icons on the menu bar, and the SpamSieve one still doesn’t show up, even though there is way more than enough space for it.

Perhaps it would help to quit and relaunch the app or toggle the Show menu bar icon setting.

Try Finder which does not have many menu items and then Cmd-drag the SpamSieve icon.

I’m not totally following this thread, so maybe this isn’t the problem.

Yep, tried that already, as well as rebooting at least a couple of times.