C-Command Software Forum

SpamSieve Public Beta and macOS 10.15 Catalina

First, please try choosing “Install Apple Mail Plug-In” from the SpamSieve menu. If that doesn’t work, the crash may have messed up Mail’s special DataVaults folder. I suggest deleting it as described at the bottom of this page.

The re-install didn’t help but removing the DataVaults folder did work, back in business. Thanks!

Uninstalled & reinstalled and mail hangs
I had Catalina installed prior to the new version of SpamSieve, but when I install the latest version of the plug-in, Mail hangs and no new mail will download unless it’s completely uninstalled and I do a reboot. Has anyone else had this problem? I trashed the datavault folder, and it didn’t help. Any other suggestions?

I’ve not heard other reports of that. If Mail is hanging, you should record a sample of it. Please include that with the diagnostic report that you send in.

Everything running fine since the newest beta.
Just wanted to say thank you for the latest beta (2.9.37b1). Ever since it was installed ( 23 July 2019 ), everything (Mail wise) has been running as before. All Is good with macOS Catalina 10.15 Beta 3(?) - and SpamSieve.

Thanks to all for the fix!

cheers!
dan

FYI if anyone else is finding that SpamSieve isn’t moving Spam messages as expected on the 10.15 beta, what worked for me was to re-do the “SpamSieve - Change Settings” wizard under the message menu. After I did that, the SpamSieve Rule and the “Train As Good”/“Train as Spam” menu items work as expected, putting my Spam in a local Spam folder and returning whitelisted messages to the Inbox.

Not working with Catalina 10.15 (19A526h)
After downloading and installing 2.9.37b1, I get this message when trying to choose SpamSieve.mailbundle in Mail preferences:

Incompatible Plug-ins Disabled

Mail has disabled the following plug-ins:

SpamSieve.mailbundle

Contact the makers of these plug-ins for versions that are compatible with Mail 13.0.

Please update to 2.9.37b3 and then choose “Install Apple Mail Plug-In” from the SpamSieve menu.

How to get beta?
It seems very hard to find the beta you refer to (2.9.37b2). How do I get it?

Never mind
As soon as I posted the last note, I got an offer to update to 2.9.37b2.

Still can’t install
Trying to install, get this message: “SpamSieve was unable to open the file ‘SpamSieve-2.9.37b3.dmg’. Please click Check Now and try again, or go to <https://c-command.com> to download the update yourself.”

You can sign up for the beta at the top of this thread.

Because SpamSieve 2.9.36’s Software Update “Download & Install” command doesn’t work on macOS 10.15, it’s best to update to the beta version of SpamSieve before installing the macOS 10.15 beta on your Mac. You can also click the “Download” button and do the install manually, according to the instructions in the Read Me file.

Beta 4 causing Mail to crash?
Since updating to SpamSieve 2.9.37b4 I have been getting multiple random crashes. I can’t say it’s SS causing it for sure, but it lines up with my updating of the plugin. Anyone else having issues?

I’ve not heard other reports of this. Please send in the crash reports.

How Do I Obtain The Beta directly from your website?
The Update function cannot open the beta and says to download it directly from your site. I am using the developer Beta of Catalina.

Please see the note at the top of this thread.

Deleting Spam identified by SpamSieve
It appears i am having a lot of difficulty in deleting my emails that have been identified by SpamSieve as spam. First the apple script fails to work failing on an error code or time out of an event. Second, when I attempt to delete these emails directly, they seem to delete but in all cases they return to my deleted folder. I can’t delete from the SpamSieve folder, I can’t deleted from my Trash folder, I can’t delete from my Junk folder. I am on the latest version of DiscardSpam apple script and on the beta version of SpamSieve, and the Beta Version of Apple MacOS Catalina.

Prior to this, I had to turn off SpamSieve, delete the messages manually, then turn it on again. Once, I had to uninstall SpamSieve, then reinstall.

Any suggestions?

Please submit technical support questions via e-mail, rather than posting here. Please include information about the error codes/messages from the AppleScript, how many messages were in the Spam mailbox at the time, etc.

However, since you’re also having trouble directly deleting messages using Mail, it sounds like a Catalina bug that you should report to Apple. SpamSieve doesn’t have any impact on operations that you do manually in Mail.

macOS 10.15 Catalina has been released, and the latest compatibility information is available here.