C-Command Software Forum

SpamSieve Public Beta and macOS 11.0 Big Sur

The current public beta version of SpamSieve has preliminary support for Apple Mail on macOS 11. You can sign up below to be notified when new beta versions are available and download them from within the app.

The beta release notes are available in the Software Update window and also in the “Version History” section of the manual (in the Help menu).

We do not recommend using a macOS beta on your main Mac, as there may be bugs that we have not had time to, or cannot, work around. With that said, we do welcome bug reports so that we can investigate any bugs and report them to Apple or try to develop workarounds. Please submit any feedback or bug reports via e-mail, rather than posting here.

1 Like

The SpamSieve 2.9.40b2 public beta adds preliminary support for macOS 11.0 Big Sur.

Michael, Re your last email, think I figured out why the recommended method Manual 7.1.1.1 D(Manually Delete DataVaults) to access from Go To Folder: ~/Library/Containers/com.apple.mail/Data
If the system finds no file once, it tries to correct the next occurrence of part of that direction to something else that may exist (fix your typing?). Did not try turning off spelling correction, but it’s very frustrating. Your instruction line added to the online manual didn’t help.
Also frustrating (yes, Terminal was not set to Full Disk Access, which I fixed and retested)… Finding DataVaults Folder. You can set the EnableBundles OK and confirm by trying it a second time to get a nil file. However (7.1.1.1, Part C,5) the write command does no good. Back to Part D 6. Getting to the folder in the Go To Folder. Getting to the Folder that way to delete it fails because of the above anomaly in typing in the dialog box. Once wrong you can’t enter it again. In any event the file isn’t living there and the plug in still fails to install for me (SIP off).

Regarding the instructions in section 7.1.1.1, there are cases where “C. Ask Mail to Reset the DataVaults” is not enough and you need “D. Delete the DataVaults Folder.” In this case, I have found that it works to use the Go to Folder… command in Finder and type the path exactly. Do not use Tab auto-completion or Finder will change the path to something that doesn’t work. We confirmed in the e-mail that you sent me that your system did have the folder in question.

The other option is to delete the folder from Terminal by entering the command:

rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults/

In order for this to work, you must first give the Terminal app Full Disk Access, and SIP needs to be off.

Yes. I did both, and it worked as documented in the email. However the end result, for me at least still wasn’t achieved. The Big Sur installation of SpamSieve mail bundle Plug-in still failed to activate. DataVaults was replaced when Mail reopened. I checked to see it removed and again with Terminal’s ls command on the the folder to see it replaced:

ls ~/Library/Containers/com.apple.mail/Data/

You seem to be using an older version of SpamSieve, not the 2.9.40b2 mentioned here that adds support for Big Sur.

That’s probably it! Will update. Thanks.

Works fine after the proper version installed. SpamSieve Public Beta in use on all OSes - three machines.

Beta 4 broke SpamSieve Plug-in version so 2.9.40b2 no longer works after MacOS upgrade. So far, I tried uninstall/reinstall of the Plug-in. I’ll try the remaining remedial steps when time permits. Just thought you’d like to know.

SpamSieve 2.9.40b3 should work with macOS 11 Developer Beta 4.