C-Command Software Forum

SpamSieve - "Train as Good" deletes email permanently

Hi,

This is the second time in the past few days that I’ve had an email which was initially identified by SpamSieve as spam, that, upon training SpamSieve “Train as Good”, causes the email to be completely deleted from Mail.

Here’s a recent entry from the SpamSieve’s log:

Mistake: False Positive
Subject: CAS-354427-MPF6FZ - Upgrade Problems CRM:01553093
Identifier: cbjv+JxXAe4W7Yb5oI9rlg==
Classifier: Encoded HTML
Score: 100
Date: 2009-12-17 00:04:30 -0500

According to my settings, this email that was originally identified as spam and subsequently 'Trained as Good", should be moved back to the Inbox and marked as Unread. But upon executing “Train as Good”, the message is deleted from the spam folder, but is not moved into the Inbox; it’s completely deleted from Mail. A search through every folder, including Spam and Trash, does not find the message. I even set up a Smart Mailbox to identify all emails that came in today; this email is nowhere to be found. I’ve lost 2 important emails in the past couple of days due to SpamSieve permanently deleting a misidentified spam message. I know that SpamSieve used to work correctly, but I can’t determine when this error started, since very few of my emails are false positives.

Does anyone have any idea what might be causing this behavior? Nothing’s changed in my SpamSieve setup for at least a month. The Inbox is an IMAP folder and the Spam folder is local, if that makes any difference.

Thanks.

Michael

I’ve never seen a case where a message was deleted. SpamSieve only ever asks Mail to move the message from one mailbox to another. It may be that, when SpamSieve looked for the inbox matching the message’s address, it found one that you’d set to be hidden. Then the message would seem to disappear, even though it’s still in Mail and still accessible with a Spotlight search (from the Spotlight menu, not Mail).

If you go to the Accounts section of Mail’s Preferences window, you can try enabling any inactive accounts and looking in their inboxes. Also, SpamSieve scans the accounts in order, so you can influence which inbox it will pick by dragging accounts higher in the list.

To prevent SpamSieve from classifying messages like this as spam, you could uncheck Encoded HTML mail is spam in the preferences.

Michael, you hit the nail on the head! SpamSieve moved the messages to my MobileMe account, which I have deactivated (I forward all mail from MobileMe to my main mailbox). I activated that mailbox, and both messages were there. I knew there was a logical explanation, I just couldn’t figure it out.

I only have 1 active mail account defined to Mail, but I have 4 others listed that are inactive. These inactive accounts forward all emails to a forwarding-only email alias, which then forwards the emails to my private email account. I just assumed (wrongly) that the inactive accounts would never have email moved to them. I did do a Spotlight search for those messages, but nothing came up. Nor did the creation of a Smart Mailbox looking for all of today’s mail.

Michael

ps - I turned off Encoded HTML email is spam. Thanks for the tip.

Hi Michael,

The same thing is happening to me. I checked the first email account listed under preferences and it’s not there (nor any other mailboxes). Tried searching via spotlight as well with no luck. These messages that I trained as good were several emails that were “mail delivery subsystem” errors - the emails bounced back to me because the recipient’s server thought I was spam.

Also from the time I originally sent out these emails I may have changed my pop account to imap.

Any thoughts on what might be happening?

thanks!

Mail does not let you change the type of an account. Are you saying that you deleted your POP account and created a new IMAP one? Perhaps the messages were in the POP inbox.

Yes, thats correct.

So spam sieve may have sent the emails to a pop account that doesn’t exist any more? (I deleted the pop account after transferring all my emails to the imap account. )

Where does spam sieve put a good email if the mailbox doesn’t exist? (Besides the first account in preferences )

Yes, I’m saying that maybe it moved the messages to the POP inbox (which existed at the time) and then you deleted the POP account (taking the messages with it).

SpamSieve looks for the first account whose address matches the message’s address, and it tries to move the message to its inbox. If no account matches (or there’s trouble accessing the inbox), it uses the inbox of the first account. If, for some reason, no inboxes exist, it doesn’t move the message.

Yes, I’m saying that maybe it moved the messages to the POP inbox (which existed at the time) and then you deleted the POP account (taking the messages with it).

I deleted the pop account right after I created the imap account (weeks ago) so I don’t think this is the case. And I marked the emails as good today.

If, for some reason, no inboxes exist, it doesn’t move the message.

In theory then, the emails must exist on my machine somewhere since I watched them disappear from my spam folder. Not sure why I can’t find then with spotlight. Ill keep looking, thanks for the help : )

I’m confused - I’ve got the same thing happening here. I’ve been using a MobileMe account for well over a year, and my previous 2 accounts are deactivated. Why does SS send messages to a deactivated account, and is there any way to stop it doing that altogether? It’s doing it specifically with messages I mark manually as Good.

The ‘deleted’ messages are showing up in Finder Spotlight. I found them in a deactivated account and moved them.

  • padmavyuha

I will be adjusting this in the next version of SpamSieve, but the current behavior is that SpamSieve tries to find an account that matches the message, and it will move the message there even if the account is disabled. To prevent this from happening, make sure that you have an active account for each of your addresses and put them higher in the list than the inactive accounts. Or you could move your old messages to active accounts and delete the inactive ones.

Thanks - for what it’s worth, my active account was already at the top of the account list, with the two inactive ones below it. Somewhere along the line, the Train as Good command stopped working as expected (it used to behave fine). I’ve now removed entirely the inactive accounts, so all being well this won’t happen to me again :).

Most likely, your active account did not have the same e-mail address as the messages that you were training, so SpamSieve skipped over it and found an inactive account that was a better match.

It’s complicated! I have my own domain, so I always use that address when creating online accounts. And of course, bloody Apple fixed MobileMe so that you can’t use your own address as a reply-to (no idea why they haven’t fixed that yet - or why they don’t want to). So I have my mail forwarded from my domain to my MobileMe account - I think. I’ll have to see what happens next time I try to Train as Good, now that there are no bogus accounts for it to dodge to.

Sounds like you need to add that address to the MobileMe account in Mail’s preferences.

As that KB article itself points out, that doesn’t work for .mac (and by extension, me.com) addresses. That was one of the first things I tried when trying to get my new MobileMe account to use my domain address as its reply-to address - but if you add that to the address list in the account prefs, your MobileMe account fails to send mail at all.

It’s crap, but I can live with it as it is, for the convenience of having mail on my iPhone. I just hope I can train as Good too. We’ll see.

My reading is that the article says it’s unnecessary to add the aliases configured at the MobileMe Web site because Mail already knows about those. It doesn’t say not to add aliases for your own domain.

It’s working fine for me…

I rejoice in your good fortune ;).

MobileMe accounts only allow @me.com aliases. And even if they didn’t restrict that, MobileMe is an IMAP-type account, so it probably wouldn’t allow adding a POP3-type account onto its list anyway, I guess. If it’s working fine for you, how have you got around all this?

I’ve made a change in SpamSieve 2.8 so that messages are no longer moved to the inbox of a disabled account.

Thanks - and please excuse any earlier sarkiness on my part, which was partly caused by annoyance at MobileMe :frowning: