C-Command Software Forum

"Train as Good" keyboard shortcut doesn't work anymore in Mail.app

I noticed that the keyboard shortcut Control-Command-S works fine to “Train as Spam” in the Mail app, but Control-Command-G no longer does.

I open my spam folder in the Mail.app
I watch the SpamSieve Log.Log with the Console app.
I select a message and press Control-Command-G.
Nothing happens in the log.
I choose Message > SpamSieve - Train as Good.
The log contains the expected message: “Mistake: False Positive”.

I thought, maybe my spam folder is overwhelming.

I open my Inbox in the Mail.app
I select a message and press Control-Command-G.
Nothing happens in the log.
I choose Message > SpamSieve - Train as Good.
The log contains the expect message: “Trained: Good (Manual)”

Just in case, I opened the Keyboard system preferences, and don’t see Control-Command-G listed.

Does Mail’s Message menu still show the keyboard shortcut next to “SpamSieve - Train as Good”?

Perhaps you’ve installed another application that is claiming that key at a global level.

Good questions/suggestions.

Yes, the menu still appeared as expected.
I just now realized that I have Spell Catcher application installed, and Control-Command-G is the default shortcut for “Ghostwriter”.

I just now changed that Spell Catcher shortcut, as I never (knowingly) use it.

Here’s how I fixed the problem (before I changed the Spell Catcher shortcut):

I re-downloaded and re-installed SpamSieve, and and from the SpamSieve menu, I chose “Install Apple Mail Plug-In”

I don’t think that would have any effect, since global shortcuts (like Spell Catcher) override application-leve ones (like Mail).