C-Command Software Forum

Train "Good" doesn't move the message

This used to work but not any longer. When I have a good message in the spam folder, select it, and then hit cntl-command-G (or the Train Good selection in the dropdown) the message stays in the spam folder. It used to move it to the inbox. Checking the log shows that the “train good” function has worked.

from the log:

Trained: Good (Manual)
Subject: Letter from Lancair
Identifier: UWt0piIVqomR0wwb5ncr3A==
Actions: added to Good corpus (607)
Date: 2010-10-25 15:11:30 -0700

Any ideas?

Thanks in advance - Hal

Which mail program are you using? What is the exact name of the folder that the message is in when you train it?

I’m using Apple Mail ver 4.3(1081).

The exact name of the spam folder in which the “good” message resides is: Spam
(no spaces fore or aft)

It sounds like it should be working, then. If you open the /Applications/Utilities/Console program and look under All Messages, do you see any error messages from Mail when you train the message as good?

No messages show up in the Console “All Messages” section.

Would reinstalling SpamSieve accomplish anything?

Probably not. Please try opening the attached script in AppleScript Editor. Select the good message in Mail, then switch to AppleScript Editor and click Run. What happens?

Selected the message, and then ran the script.

A message window appeared that said, “Moving message: false”.
Nothing appeared to happen in Apple Mail to the selected message.
Also, the script generated an error per attached.

That means that SpamSieve didn’t think the message was supposed to be moved. Maybe you need to use the “SpamSieve - Change Settings” command to tell it that you want good messages moved (though that’s the default). If that isn’t it, please try again with this script and let me know what happens.

>>>>>Maybe you need to use the “SpamSieve - Change Settings” command…

That worked, Michael!!! Apparently the settings got changed to not copy the message to the inbox.

Thanks for the super support. I love this program.