C-Command Software Forum

2.9.1 Giving Error Message

I just tried to install 2.9.1 and I got the following error message.

“The operation can’t be completed because some items had to be skipped. For each item, choose File > Get Info, make sure “Locked” is deselected, and then check the Sharing & Permissions section. When you are sure the items are unlocked and not designated as Read Only or No Access, try again.”

It doesn’t redirect me to those items in question so I don’t have any idea what they are. I even attempted to remove the existing Spamsieve and do a clean install but no luck.

Any ideas?

Thanks,

Paul

Is SpamSieve itself reporting this error, or is the Finder reporting it when you try to copy SpamSieve to your Applications folder?

I’m not certain. I’ve copied the entire frame contents. There is reference to notifying Apple. It appears to be a Spamsieve generated report.

Process: SpamSieve [14300]
Path: /Applications/SpamSieve.app/Contents/MacOS/SpamSieve
Identifier: com.c-command.SpamSieve
Version: 2.9.1 (2901040)
Code Type: X86-64 (Native)
Parent Process: launchd [141]

Date/Time: 2012-04-30 14:10:17.495 -0400
OS Version: Mac OS X 10.7.3 (11D50b)
Report Version: 9

Interval Since Last Report: 1563576 sec
Crashes Since Last Report: 6
Per-App Interval Since Last Report: 271317 sec
Per-App Crashes Since Last Report: 6
Anonymous UUID: E25A69F4-F33D-49FF-93DD-119A8F16D183

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @executable_path/…/Frameworks/MJTApplication.framework/Versions/A/MJTApplication
Referenced from: /Applications/SpamSieve.app/Contents/MacOS/SpamSieve
Reason: image not found

Binary Images:
0x100000000 - 0x100000fff +com.c-command.SpamSieve (2.9.1 - 2901040) <A76B3A42-9654-0643-4B85-F8739E07D31D> /Applications/SpamSieve.app/Contents/MacOS/SpamSieve
0x100004000 - 0x100067fff +com.c-command.MJTFoundation (??? - 1.5) <2C9849B3-288E-FF43-892E-2BECEED0569C> /Applications/SpamSieve.app/Contents/Frameworks/MJTFoundation.framework/Versions/A/MJTFoundation
0x7fff6200b000 - 0x7fff6203fbaf dyld (195.6 - ???) <0CD1B35B-A28F-32DA-B72E-452EAD609613> /usr/lib/dyld
0x7fff90a9c000 - 0x7fff90a9cfff com.apple.Cocoa (6.6 - ???) <7EC4D759-B2A6-3A99-AC75-809FED1500C6> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa

Model: iMac12,1, BootROM IM121.0047.B1F, 4 processors, Intel Core i5, 2.5 GHz, 4 GB, SMC 1.71f22
Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3231554538424655302D444A2D4620
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x02FE, 0x45424A3231554538424655302D444A2D4620
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x9A), Atheros 9380: 4.0.61.5-P2P
Bluetooth: Version 4.0.3f12, 2 service, 18 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: ST3500418AS, 500.11 GB
Serial ATA Device: HL-DT-STDVDRW GA32N
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x850b, 0xfa200000 / 3
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 5
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
USB Device: Officejet 6300 series, 0x03f0 (Hewlett Packard), 0x5311, 0xfd140000 / 5
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 4
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfd110000 / 3

It looks like the first error was from the Finder, saying that it couldn’t copy the SpamSieve file. And then you tried to launch SpamSieve and, since it was only incompletely copied, the system generated a detailed report saying that one of the essential files was missing. I’ve checked the SpamSieve download, and as far as I can tell the permissions are correct and no files are locked. And the problem does not seem to be widespread. So I’m guessing that the problem is on your Mac (perhaps an anti-virus utility that’s preventing the files from being read) and that the Finder’s error message is slightly misleading. It might help to restart your Mac and try again.

apple mail wouldn’t open
when i launched apple mail (Lion 10.7.3) this morning I got a message saying that mail had quit because of an error with spamsieve.

trashed spamsieve in order to get my mail.

all the mail came into the spam mailbox.

tried to re-install spamsieve 2-2.9.1 and got an error code -8003

restarted the computer and was able to re-install spamsieve

relaunched mail but spamsieve doesn’t seem to be working. mail still comes into the mail spam box.

I tried a restart but had no luck. I have NO anti virus that isn’t anything standard with the computer, a mid 2011 manufacture 21.5" running 10.3.7. I still get the same messages upon attempting to install Spamsieve. What I finally DID do was put all existing Spamsieve apps and folders into the trash and reinstall. THAT seems to have done the trick.

Thanks

This typically means that SpamSieve’s plug-in isn’t installed. Please see the Why is every message going to the Spam mailbox? page.

The folders don’t matter. I would have suggested deleting the old copy of the app, but your very first message said that you weren’t able to do that. That’s one of the reasons I thought something else was going on on your Mac; it’s just a regular file so there’s no reason for it to be undeletable. Glad you got it working, though.

I apologize for my original erroneous post. Thanks for your help!