C-Command Software Forum

Ability to ignore hidden folders

I also use TagSpaces that writes metadata to hidden .ts folders. Currently they are also showing up in eagle filer. Is there any way to have EagleFiler ignore hidden folders?

Yes, please see the UnscannedFilenames setting.

This is built into EagleFiler 1.7.4.

I’m having some trouble trying to ignore hidden folders with the UnscannedFilenames setting.

I have some ipython notebooks checkpoints folders that I’d like EagleFiler to ignore when scanning for new files, so as not to import them to the library. These folders are always named .ipynb_checkpoints but when I tried either the options below, none of them actually seem to change the EagleFiler behaviour:

defaults write com.c-command.EagleFiler UnscannedFilenames -array '.ipynb_checkpoints'
# or
defaults write com.c-command.EagleFiler UnscannedExtensions -array ipynb_checkpoints

Typing mkdir .ipynb_checkpoints in the terminal and then performing a Rescan in EagleFiler still imports the folder.

What would be the correct setting to ignore these hidden folders?

PS. using EagleFiler 1.8.13

Apologies for a new reply but it was already too late for editing the previous one.

I also tried to quit and re-launch EagleFiler, but it still imports .ipynb_checkpoints folders.

I wonder if there was a typo in your Terminal command, because I tried entering:

defaults write com.c-command.EagleFiler UnscannedFilenames -array '.ipynb_checkpoints'

and it worked. Could you try it again? If it still doesn’t work, please send a diagnostic report.

Not sure what happened before, but using the Terminal command from Michael, quitting and re-launching EagleFiler (possibly twice) seems to have solved the problem, and EagleFiler no longer imports the hidden folder to the library.

Many thanks for the support.
Pedro