C-Command Software Forum

Address Book / Exclude My Address just isn't working

Hi,

  • Running Mavericks here. OS X 10.9.1, Mail 7.1 (1827), and SpamSieve 2.9.13b1
  • My email address is listed in Contacts in the ‘me’ card. Confirmed several times.
  • Address doesn’t exist anywhere else in Contacts.
  • SpamSieve is configured to
    • Use Mac OS X Address Book
    • Exclude My Addresses
    • My address is sender-blocklisted.

In spite of the above, I’m still getting the following allow event, now several dozen times a day from a very persistent and obvious spam source spoofing my ‘From’ address:
Reason: sender <myemail@ddress.here> in address book

I’ve refreshed & toggled the settings multiple times, trained hundreds of these messages, but I just can’t get this functionality to stick. Any ideas?

Thanks very much

Please make sure your address is listed in one of the e-mail fields on the “me” card. It won’t work if you have it entered as, e.g., a phone number.

Also, make sure that this is the card that shows up when you choose “Card > Go to My Card” in Contacts.

Confirmed on both counts. It’s in an ‘email’ field, and this is the card that is opened with “Go To My Card”.

Please contact me via e-mail, and I’ll send you a debug build of SpamSieve so that we can further investigate this problem.

The address book card looks correct in the Contacts application, but logging it to the Console only shows one e-mail address. This looks like an address book malfunction. You could try creating a new card, adding the same info, and then designating it as “your card.” That might get it to include all the addresses.

Another options would be to use the ExtraAddressesToExclude feature to manually add the addresses to SpamSieve.

I’m glad to hear that recreating the card fixed the problem.

Same problem…
I too have this problem. SpamSieve will not find my address card. I have followed the advice in this post and recreated it but it still won’t work. I have also tried the Terminal command above but I’m not familiar with Terminal so I don’t believe I am actually ‘entering’ the command (I copied and pasted the command above, substituting my email addresses, then pressed ENTER) as pressing the Enter key just drops me down a line.

Thanks,

Simon

Yes, it’s just supposed to drop you down a line. If the command worked, entering this command:

defaults read com.c-command.SpamSieve ExtraAddressesToExclude

should show something like:

("username@domain.com")

You can also click this link to make SpamSieve log (to Console) the information it’s reading from the Contacts database, and this link to turn off logging.

Michael Tsai, thanks. The email addresses showed so presumably, it’s all working now