C-Command Software Forum

after training for good, SS sends mail to only one account

When I train a message to be a good message, what used to happen is that SS would send the message back to the email account in which the message originally came from. Now, it sends ALL good messages to one account, my default account. How do I get it to send the messages back to the account they were originally sent to? This is really annoying and I can’t seem to find an easy fix.

Thanks,

Antonio

Are you using Apple Mail? Please contact me via e-mail, and I’ll get you a beta version that tries to address this.

This is fixed in SpamSieve 2.9.6.

Bumping this topic because SS sends “train as good” messages to the wrong email account. For example, a message addressed to a gmail address is tagged as spam by SS. I use “train as good” in SS, and SS send that message to my .me account. I don’t see a preference for this. I’m on SS 2.9.7 and Apple Mail 6.5.

There are no known bugs with this feature. SpamSieve identifies the account based on the account that the message was addressed to. If the To/Cc address in the message doesn’t match any of the e-mail addresses in Mail’s preferences, SpamSieve picks the first account. Please see Account Aliases for how you can make sure all your addresses are listed.

I just verified that each account had the proper email addresses/aliases in the preference section. Tried to move a gmail message marked as spam, and SS moved it to the wrong (icloud) account again.

Could you send me (via e-mail) screenshots showing the raw source of the message in question and also the two accounts in the preferences?

edit: Sent

The problem ended up being that bluloo’s Gmail e-mail address was not correctly entered in Mail’s preferences.

I am having the same problem, Email caught as spam via iCloud, is being sent via Tencent to my inbox when SS trains as good.

I have a lot of aliases via iCloud (dot mac/mobile me), but thats normal.

Please check that the “To” address for those e-mails is listed in the Email Address in your iCloud account in Mail’s preferences.

The Account information>Email Address is greyed out, and I am unable to enter anything. All the email addresses are in the Alias section though.

Could you please send me (via e-mail) screenshots showing the raw source of the message and also the account in the preferences?

Thanks for sending the screenshots and raw source. It looks like the message’s To address is completely different from the “Email Address” field in Mail, so SpamSieve doesn’t think that they match. To tell SpamSieve about the alias, you can choose Custom from the Alias pop-up menu and then enter all your aliases (separated by commas) in the “Email Address” field.

They are already there, it is managed by iCloud. I have six Aliases there. I am sending you another screen shot.

Yes, I see them in the Aliases pop-up menu, but you need to type them in the Email Addresses field in order for SpamSieve to be able to access them.