C-Command Software Forum

All spam emails still appear in Inbox and Spam folder

Hi,

Fairly new to spamsieve, so I am not sure if what I am seeing is a feature, a setting - or just the way it works! I have trained spamsieve fairly consistently over the last week. However, using Apple Mail, all the emails still appear in both the Spam folder and the Inbox - though coloured in grey, blue orange etc. Should they still be in the Inbox? I thought it would filter out the spam so as to not clutter my inbox - not highlight them for identification - which it does do very well. How do I ensure that emails do not appear in my Inbox at all - only in the Spam folder for checking.

Normally the messages will be moved to the Spam mailbox so that they no longer appear in the inbox. First, please check your SpamSieve rule in Mail’s preferences to make sure it’s set to Move Message rather than Copy Message.

If that’s not the problem, my guess is that you’re running into an Apple Mail bug in macOS 10.15 that, for a small number of users, causes rules to copy messages instead of moving them. There are some workarounds described on this page:

  1. Recent versions of Mail have problems communicating with certain mail servers. Mail is more reliable at moving messages from the inbox to another mailbox on the same server than it is at moving the messages to a local mailbox. The Using a Spam Mailbox on the Server section of the manual explains how you can store your spam on the IMAP or Exchange server, so that Mail is better able to move it out of the inbox.

  2. A bug in macOS 10.15, affecting a small number of customers, can prevent messages caught by the normal SpamSieve rule from moving to the spam mailbox, leaving them colored in the inbox. It may help to click this link to tell SpamSieve not to mark spam messages as junk on the server. You can also work around this by instead using an Apple Mail Script Rule.

Are you still seeing this issue with macOS 10.15.4?

No - thanks. working fine now!!