All spam messages colored gray

Hi Michael, I just updated SS to v3.0 after updating to Sonoma. I think I configured everything right; now while I am “training” I see that all my messages that get marked as spam are colored gray with beige text. I assume that they are “fully” spam and thus all the same color. Yet looking in my spam folder, every single message is gray/beige, which I take to mean that SS is not catching any spam but is instead relying on me to “train as spam” individual messages. It doesn’t seem to be doing it on its own. At what point do messages start getting automatically caught, and likewise get colored according to their “spaminess”? Having them color-coded was really helpful! Thank you!

Could you check the Filtering settings to make sure that Color the background according to how spammy it is is checked?

You can also check the Log window to see whether any messages are being Predicted: Spam. If not, there’s a setup problem.

Thanks, Michael. The “Color background according to…” box is checked. The Log window all shows “manual” training since I updated to v3.0. Before that, all the entries show “Predicted Good/Bad.”

It sounds like Mail isn’t sending it any new messages to filter. Please see this page.

I checked all my setting against all the manual tutorials and they all seem to be set exactly as suggested. I also followed these instructions: “In [Settings ‣ Apple Mail ‣ Filtering], check the [Add green flag to unread good messages] and Including in the inbox boxes. Any new, unread messages, received from now on, should either be moved to Junk or to the Trash (if they’re spam) or marked with a green flag (if they’re good). Messages left in place with no green flag were not been processed by SpamSieve.” I am looking at the log record now and I notice the last entry says “Log Entry: Error unflagging green inbox messages: Mail got an error: Can’t get message id 1311203 of mailbox “Inbox” of account id “475DD969-01D7-4AD0-BF39-C4188159075E”.” So something is not right…

That part is diagnostic. Did you do the part where you set it up to filter these messages:

You can enable the Filter spam messages in other mailboxes option and add the inboxes to the Select Mailboxes to Filter… sheet. Then SpamSieve will check the inboxes itself, to filter them without relying on the Mail extension.


That probably doesn’t indicate anything interesting.