C-Command Software Forum

Alternate Location for Mail data files


I wanted to move the Mail data files from their normal location within ~/Library. This is mainly because ~/Library contains a lot of stuff that does not warrant backing up (the biggest of which is ~/Library/Caches) so I should like to avoid backing up the Library folder. I can get Mail.app to work by placing an alias to the real Mail data files in ~/Library folder, however, SpamSieve does not then work.

Is there a way of having SpamSieve work if the Mail data files are not really in ~/Library, or, alternately, does one recommend that I move the Caches files outside ~/Library - and then use an alias in ~/Library to fool the applications that want to put their caches in that folder.



It should work to quit SpamSieve and replace:

/Users/<username>/Library/Application Support/SpamSieve/

with an alias or symlink.

Sorry - maybe I’m being dumb; but if I replace /Users/<username>/Library/Application Support/SpamSieve/

with an alias or symlink, what should that alias point to? (My desire is to have the Mail data files out of ~/Library - not the SpamSieve folder.)


It should point to the new location of the folder.

I presumed that you would want to move your SpamSieve files out of ~/Library, too. Don’t you want a backup of all your training data?

SpamSieve doesn’t care where the Mail data files are. Mine have always been outside of ~/Library.

Still struggling

Thanks, Michael, That you think there should be no problem moving the Mail data files, explains why we were apparently talking at cross-purposes.

I have moved the Mail data files (to ~/Documents/Mail) and put an alias in ~/Library pointing to this folder. Mail.app runs without problem.

However, when I run “SpamSieve”/“Install Apple Mail Plug-In”, SpamSieve responds “Apple Mail Plug-In not installed” - and suggests that I drag the SpamSieve.mailbundle to the requisite location by hand (presumably in my case, ~/Documents/Mail/Bundles). When I have done that (though in fact SpamSieve.mailbundle was there already) and restarted Mail, there are still no SpamSieve options on the Message menu.

And if I continue with making the SpamSieve rule, then every incoming message is now marked as spam - which is, of course, an intended pre-cursor to the real operation of SpamSieve.

Any idea about what I am doing wrong?


Thanks for the report. It looks like, while updating some code, I introduced a bug where SpamSieve requires a symlink rather than an alias for redirecting Mail’s folder. Please try replacing your alias with a symlink or e-mail me to get a pre-release version of SpamSieve that fixes this bug.

This is fixed in SpamSieve 2.8.3.