C-Command Software Forum

Anyone figured out Firefox 3?

With each new version of EagleFiler, I install Firefox 3 and try it again. I understand the problem lies with Firefox, but I still hope. With EF 1.4, I tried a bare installation of FF3 with no extensions - no go. Even worse, after I removed FF3, FF2 failed to import too, until I wiped all vestiges of FF off my system and reinstalled FF2.

Of course, on a Mac I do NOT use as my main machine, FF3 works fine with EF.

So… Has anyone figured out a pattern to the installations of FF3 that work and the ones that don’t? Has anyone had a “bad” installation go “good”?

I haven’t, except that I’ve never seen it not work on a clean Mac OS X installation with a bare installation of Firefox. My hope is that the new bookmarklets will make Firefox 3 a bit more pleasant to use with EagleFiler if you happen to have one of the “bad” installations.

<sigh> Maybe I’ll have to with until OS X 10.6. I cannot imagine going through a clean Leopard (re)install and upgrade. The bookmarklets are great, but they do not do the option-F1 trick to let me tag and comment on the fly.

Forced to FF 3
Firefox just forced me to upgrade to v3, so I may have to try to figure this out. I really really really miss the ability to tag imports as I grab them.

I recently read that the Firefox problem may be related to Default Folder X.

Yes! - Default Folder X is the culprit
If I uninstall Default Folder X and restart, the capture key works! Turning DFX off is not enough - a restart is necessary. This is with the very latest build (4.1.1d6) on the St Clair Software web site. I have sent a note to St Clair.

More information here. It’s possible for the Firefox bug to manifest itself with the new Default Folder X, and even without Default Folder X, but updating to Default Folder X 4.1.1 should solve the problem for most people.

It works!
I am not sure upgrading to Default Folder X 4.1.1 is necessary, because that alone was not enough in my case. But adding Firefox Default Folder X’s exception list, as mentioned in the hint, did the trick. Finally!