C-Command Software Forum

Apple Mail is turing SpamSieve rules off

Hi,

I have downloaded the demo of SpamSieve and trained it for two days and the precision is amazing. One (or two) problem(s) though: Every time I quit Mail and restart the SpamSieve rules i Mail are turned off (they are at the top of the list). Also, I created one Spam folder but suddenly I had two of them. I have two mail accounts so maybe this is normal?
I am using Mail 2.1, Mac OS X 10.4.10 and SpamSieve 2.6.4

LAAK

The SpamSieve rule is just like any other Mail rule, so if it’s getting disabled that’s a general Mail problem, unrelated to SpamSieve. You might want to try running Disk Utility to repair your disk. It’s only a guess, but that might allow Mail to save its rules to disk.

I saw this problem once before, and it was solved by manually editing the file where Mail stores its rules. Once the rule was enabled, it stayed enabled. If you’d like to go that route, you could quit Mail, then open the file:

/Users/<username>/Library/Mail/MessageRules.plist

and change the part:

<dict>
    <key>Active</key>
    <string>0</string>
    ...]
    <key>RuleName</key>
    <string>SpamSieve</string>
    ...]
</dict>

to:

<dict>
    <key>Active</key>
    <string>1</string>
    ...]
    <key>RuleName</key>
    <string>SpamSieve</string>
    ...]
</dict>

That is, just change the 0 to a 1.

That’s not normal, but it probably isn’t a problem. SpamSieve will always use the top-level local mailbox called “Spam” unless you tell it otherwise.

Problem solved…
Hi Michael,

Thank you for your quick reply!
I ran Disk Utility and it said “No repairs necessary.”
BUT both my problems were solved after restarting!

Thanks
LAAK

Oops…
The problem came back. Now I’ll try to edit MessageRules.plist.

LAAK

Didn’t help either…
…but when checking the editing of the rule I found that Mail had changed from “Spam” to “no mailbox chosen”!

Now it seems to work OK so I bought SpamSieve. I am very impressed with its precision and ease of use!

Regards

LAAK