C-Command Software Forum

Apple Mail SpamSieve rule disabled

Running the latest MacOS v11.2 Big Sur. Since the last update the Mail rule for SpamSieve is disabled on startup. I’ve done all I can to correct it but no luck. It’s a bit of a pain as it allows spam to be received in my inbox when I first startup for the day. I turn it on and all is fine but the notifications and the spam are a bit annoying. The plugin itself is always loaded.

Please try #2 here to speed up Mail’s launching and see if that helps.

It seems to have helped. I quit and restarted a couple times without the error. I’ll probably know more tomorrow. The interval of time between launching the app and and when the message window appears is quite long it seems to me. I’m rebuilding the mailboxes to see if that helps. I don’t have an abnormally large database of messages.

I’m glad that helped. About how long is it taking for Mail to launch now? If there are further errors, you could click this link to enable some additional debug logging and then use the Save Diagnostic Report command in the Help menu to send in the errors that are logged.

I don’t think rebuilding the mailboxes will affect this issue.

The app “launches” right away but it’s about 1 minute 10 seconds for the message viewer window to appear. I’ll generate the log and send it.

Attached is the log file.

The launching looks normal from SpamSieve’s perspective. If you want me to look into why Mail is taking so long to show the message viewer window, you could record some sample logs from Mail during that 1:10 interval.

Thank you. I won’t be able to do that until tomorrow but I will look into it. I appreciate your help.

SpamSieve is performing as it should. It’s enabled upon startup. I ran Cocktail thinking that maybe that would clean up some unnecessary files but now it’s taking just over 2 minutes to get to the message window. I’m sure this is not a SpamSieve issue. I’m also experiencing an issue with my backup software, ChronoSync. Upon completion it launches Mail and sends 2 emails. That is not working correctly. I believe this all started when I updated to the latest Big Sur last week. I have a MacBook running Catalina where Mail and SpamSieve are working fine. About 30 seconds to launch Mail.

Meanwhile, I was looking at Activity Monitor and the Sample Process menu is disabled. I’ve tried several thing to get it to be enabled. No luck.

When I’ve seen this happen before, Mail was waiting on some other system service, like the Contacts database.

It should be enabled after you select Mail in the list.

That works. I thought I had done that. Guess not.

I got rid of a couple of email accounts in Mail that were inactive. On one the login password was incorrect. That was probably the culprit. Now Mail launches in about 15 seconds.

Thanks for working through this with me. I appreciate it.

1 Like