C-Command Software Forum

Auto Update no longer downloading

SpamSieve auto update is informing me that I should update 2.6.4 to 2.6.5. However when I click on Download and Install I get a pop up telling me the update is downloading but it never does. I same problem happens if I choose Download rather then download and install. Updates worked fine before moving to Leopard. Thinking that it might be a firewall issue I added SpamSieve to allow incoming connections but this did not solve the problem. Any ideas, I did a search on the forum, but did not see anyone else having the same issue.

Hmm, I haven’t heard of this happening before. Do you see any errors in Console? I don’t think it’s a firewall issue, because SpamSieve doesn’t need incoming connections. It just needs to download over HTTP, and if it figured out that there’s a new version it must have already done that successfully.

Michael,

This is what console reports:

11/18/07 3:05:56 PM SpamSieve[383] Could not create the folder

/Applications/iWork '08/Keynote.app/Contents/Frameworks/SFRendering.framework/Versions/A/Resources/Frames/Storyboard.sfrframe/Contents/Resources/Storyboard_Mask_02.png

because there is already a file there. To continue, please rename the file or move it to another folder.

Does it print that in response to trying to download an update?

SpamSieve ordinarily wouldn’t be doing anything in iWork’s folder. However, it’s possible that your downloads folder is erroneously set to that location, or that there’s a damaged alias file that SpamSieve is resolving to that location.

Yes

When I look at the file path for my downloads folder in Finder its showing as being in MacHD/Users/Bob/Downloads. I’ve been able to download updates for other programs such as 1Passwd, and Pathfinder without any problems. I can download 2.6.5 manually from your web site. Should I just install it that way?

As far as I know, those applications use Sparkle for their auto-updates. Sparkle downloads into a temporary folder and then deletes the .dmg file. SpamSieve asks the OS for the downloads folder and saves the .dmg file there.

Yeah, that’s probably the easiest solution. E-mail me if you’re interested in debugging the Software Update feature.

I did that. It installed just fine. I

As the debug build shows, the problem was that your downloads folder was set to that PNG file.