C-Command Software Forum

background image issues on 10.6

Hello - I’ve followed your directions in the manual for adding a background image:

  1. create folder with app and .background folder with the background image in it
  2. create read/write dmg via DropDMG from the folder
  3. change dmg’s view properties and set the background image (by dropping the image from the dmg to the view properties’ background image drop area)
  4. create read-only dmg from read/write dmg via DropDMG

I did all this on Snow Leopard and it shows up just fine there. On Leopard, however, the background doesn’t show up and the window size is actually slightly off.

This is all with DropDMG 2.8.6.

Apple has confirmed that this is due to a bug in Snow Leopard.

OK - is there a work-around, or do I need to revert to Leopard to create my dmg?

That’s the only workaround that I know of.

OK - when I create it on Leopard, it shows up fine there, but when I open it on Snow Leopard, it comes up with the top and side bars and the window is the wrong size. Any clues?

FYI - I just took the read/write dmg that I created on SL, changed its view properties, including background image, and then created the final read-only dmg, all on Leopard.

Does it make a difference if you create the image on Leopard?

Yep, it did. Seems fine now on both SL and L. Be curious to know when/if this gets fixed in SL.

when I open it on Snow Leopard, it comes up with the top and side bars and the window is the wrong size. Any clues?
FYI - I just took the read/write dmg that I created on SL, changed its view properties, including background image, and then created the final read-only dmg, all on Leopard.

Did you ever mount the image in Snow Leopard before setting the view properties in Leopard? If so, please try not doing that. Or create the image entirely on Leopard.