C-Command Software Forum

Background Images

I too am having trouble with background images and auto-open (atleast a folder, as I understand it will not auto start on mac os x). I have been successful with creating a custom icon when the disk is mounting (not successful in creating a badge on the dmg icon). However I would really like to add a background image and have a folder auto open when the disk is inserted.

I have tried to follow the directions by making sure I am linking to the image saved on the disk, burning as a read only etc, but no hope. I’ve also created an empty folder and deleted it

My disk utility is set to auto open read only discs, and I have Auto open image window after mounting selected in preferences on DropDMG.

Have tried burning folder with DropDMG and Roxio Toast 6.
Please help!

You’ve listed various problems, but it will be difficult for me to help you if you don’t say more specifically what you did and what the results were. One issue at a time, please.

I don’t understand the distinction that you’re making there. Perhaps you could post some screenshots.

DropDMG’s auto-open feature is for opening the volume, not a folder within the volume.

It would help if you could tell me exactly what you did, rather than saying that you followed the directions. I don’t know what “burning as a read only” means.

DropDMG’s preferences for auto-open and icons apply to disk images, not burning. To burn a custom icon, you should create a disk image, make sure it’s correct, and then burn the image. Don’t burn the folder directly.

Thank you for your prompt reply.

These are the steps I have tried to take to have a background image appear.
-Saved an image as a jpg
-put the jpg with in the folder that I want to create a disk image with.
-Set the view options with the folder to show a picture, and adjusted the documents and window size to the desired look and size.
-Dragged the original folder into dropDMG with the prefrences in DropDMG set to: dmg read-write, use custom icon for mounted image, auto-open image window after mounting
This creates a .dmg and when I mount it my custom icon appears for the folder. :slight_smile:

I go in and again make sure the background is directed to the image within this folder and then change the settings in DropDMG to a .dmg Read-only and drag the new folder onto the DropDMG application which creates a new read-only.dmg

they I have dragged both the new read-only .dmg to roxio toast to burn a cd, and also another cd of the folder that opens when I double click on the .dmg (that shows my custom icon). When I take both discs to another mac with os x 10.4 my custom icon transfers, but the background image does not and the icons are moved to a different arrangement. I would really like to have it look more like the attached screen shot (note this is not my file, but from another application I used).

background images
Note: I also tried to create an empty folder and then deleted it before I burned the disk to cd as suggested in the directions I found on your site.
Here is a screen shot of my folder

These are not the proper steps. You need to first create a read-write image, and then set the background picture on the mounted image, not on the folder. You should create the read-only image from the read-write image, not from the folder.

Thanks Michael! This description helped me solve my folder background issue. I’ve been trying to set a window color background for my .dmg files, and it would never stick. As I now know, this is because I was naively setting it on the source folder, rather than on a read-write image.

Although not explicitly mentioned anywhere that I’ve read, this procedure does work for setting image window background colors, as well as background images.