C-Command Software Forum

Big Sur 11.0.1 issues

I just upgraded to BS 11.0.1 and using SS 2.9.40.

I have been using SS for many years, so there is a lot of training that has been working fine until now. Although it is showing the spam changing to blue hilight color in my inbox, it is no longer automatically moving it to the spam folder as usual. However if I hilight the spam messages and choose to Train as Spam, it then moves it to the spam folder.

Has something been untoggled?

1 Like

It sounds like the SpamSieve rule in Mail has been turned off or deleted. Please see Step 4.

Exactly, since Big Sur spam in seen in BOTH inbox colored as spam and in spam folder. I can either delete it or “Apply Rules” and it moves to correct place. So being a decade long user, I am clearing my spam with “Apply Rules” multiple times every day. And yes, the rule is checked. This happened before, you had me build a “Move if Spam Sieve” rule which does not help and often just makes mail run very vary SLOW. What do I do?

1 Like

It had not been turned off or deleted and was properly checked to be enabled.
I went ahead and deleted the originial and created the rule again.
However it appears to still be leaving the messages in my inbox.

If the messages are being colored as spam but not moving to the Spam mailbox, yet the rule works when manually applied, you are probably running into a Mail rule bug (introduced in macOS 10.15, continuing in 11.0). For some users, the script rule will help. The other option is to work around the bug by changing the location of the Spam mailbox (#4), e.g. if your SpamSieve rule has selected a mailbox under On My Mac, change it to one on your mail server, or vice-versa.

thanks so much will try it

I created a new Spam folder on my server (which is google). I deleted the original On My Mac. I then deleted the rule and recreated, making sure I chose the new Spam folder on the server.
However the spam still goes blue and remains in my inbox, but now when I tell it to train as spam, it recreates a new Spam folder On My Mac and sends it there.

I will now try the suggest Script rule you also suggested.

Same results with the script rule. JUst a tad slower doing it.

I’m not sure why you are seeing different results, as the workaround has been successful for the other users I’ve heard from.

  • If you select the blue messages and choose Message ‣ Apply Rules does that move them to the Spam mailbox?
  • Do you have any other Mail plug-ins installed?
  • Any rules above the SpamSieve one?
  • Are you getting a mix of colors or just blue?

That part is expected because there’s a separate setting to control where trained spam messages go. It’s also fine to leave it using the local mailbox if that’s working.

I have now done it two more times to make sure I was not missing something. All three times have been the same results as I have described above.

When I do the Apply Rules now, I do not see where the messages go. They do not go to either spam folders (on my mac or server) or any other folder I have found. They just disappear.

I have no other plug in running or even installed.

SpamSieve is top rule. The only other rule is the News from Apple

Blue is the only color I get

You seem to be running into a Mail bug where it deletes messages instead of moving them. This is happens for some users on macOS 10.15 and 11.0, whether or not SpamSieve is in use.

Is the server Spam mailbox that you created located on the same server as the inbox that received these messages? Keeping messages on the same server is usually a workaround for this bug. However, if that’s not working on your Mac, I would suggest:

  • Enabling SpamSieve’s backup feature so that you can recover any messages that Mail loses.

  • You can set your SpamSieve rule to flag the messages in blue instead of moving them. This will avoid the bug while still separating out the spam messages for easy deletion.

    • You can create a smart mailbox called Spam that looks for messages with the blue flag. This will make it easy to review and delete the spam.

    • You can create a smart mailbox called Not Spam that looks for messages not in the Spam smart mailbox. This will make it easy to see a spam-free “inbox.”

The originial Spam folder I was using is On My Mac and the Inbox is on the Google server. Now I have the Spam folder on the Google server (via your suggestion above).

At this point I am used to just manually applying the rule. I’m going to wait it out and hope either the next MOS or SS update corrects the issue.

I appreciate all your help. Thank you

OK, that’s good. I had thought from above that you were saying that the messages disappeared when applying the rules manually.

Well now with an update to both SS and MOS now updated to 11.1, a new issue has deleveloped.

When trained spam comes in it now correctly goes to the Spam folder on the Google server. However within a few minutes, it then transfer back to my inbox. I can actually see this happening even as I post this message.

This seems to be a general issue that some people are seeing with Big Sur and Gmail, even with regular Mail rules and SpamSieve not installed. If you look at the Gmail Web interface, does it show the message in Spam or Inbox or both?

Does it help to change the SpamSieve rule in Mail to move the messages to a Spam mailbox under On My Mac?

I’ve also heard that it may help to set up the Gmail account in Mail as a regular IMAP account (entering the mail server information directly) rather than a Google account.

I switched the rule to go to the Spam folder On My Mac, which brings it back to my original issue of it going to the Spam folder but leaving a copy in the Inbox.

I already had my acct set up as regular IMAP. Is there another option I should have it?

When that happens, is it still in the inbox on the Gmail Web site? Or only in Mail?

Have you tried the workaround in #5 here? That can help Mail move messages more reliably.

IMAP is usually good, but you could try setting it up as a “Google” account if necessary.