C-Command Software Forum

Bootable System 7 CD

I’m trying to make a bootable System 7 CD for a very old Mac. I tried to make a read-write .dmg from a bootable CD, but it seems to be read-only, and I can’t add the utility I will need to the image. I tried making a .sparsebundle too, same problem.

Unfortunately, macOS removed support for writing to HFS Standard volumes in 10.6.

So I made an old-style .img of a System 7 install disc using DropDMG and used SheepShaver to copy the extra files onto the image. Then I used DropDMG to burn it to a CD. But the old Mac refuses to boot off it.

My guess is that you ended up with an HFS+ disk image because macOS no longer supports creating HFS Standard ones. And I don’t think a Mac that came with System 7 can boot from HFS+.

Is it possible for you to create and edit the .img within SheepShaver, e.g. using Disk Copy?

SheepShaver didn’t work out.

So I made an .img of the install CD on the ancient Mac, transferred it to the current Mac, mounted it with DropDMG, added some utilities, and burned it to disc using DropDMG. But when I try to boot the ancient Mac off that CD, it boots off the hard drive instead. Any clues?

It seems like that should have worked. Did the old Mac let you select the CD to boot from in the Startup Disk control panel? Have you tried narrowing down where the problem is by making sure that it works with the initial .img that you made? Which app did you use to create that?

I made sure the CD was chosen in the Startup Disk control panel, but it boots off something else anyway.

I tried burning an unmodified .img - just the install CD - and that won’t boot either.

I believe I created the .img with Disk Copy 6.1.3. (Version 4 wouldn’t let me do it.)

I wonder if you would have better luck using Toast. I recall that being useful for making bootable images and discs in the OS 9 days.

I used an old version of Toast. It was able to copy a bootable CD, but I couldn’t make my own CD. I’m giving up.