C-Command Software Forum

Bug on Eagle interface toolbar

Hi, I am evaluating (trial) version of Eagle and I found a bug on the interface, specifically on the toolbar.
It happens when I try to customize it.
Every time I choose to edit/customize the icons on the toolbar, they get bigger, and bigger, and bigger.

Pictures will tell better than my description, I am attaching them below.

My system is MacOS 10.15.3 Beta (19D49f)

after 3 customizations:

(I tried to post 4 pictures but I am a new user and cannot attach more than one. The other pictures was to show how they get bigger [progressiving get bigger each time]. So I am attaching the 4th picture. where they are already Huge)

Thanks for the report. I’m not seeing that on macOS 10.14.6 or 10.15.2. I’ll try testing it with the beta later today. Could you tell me more specifically what you are doing that triggers the problem? Does it occur when you open the toolbar customization sheet? When you dismiss it? Only when you add/remove toolbar buttons?

Hi, yes! Its very simple:

Right click toolbar, select “Customize Toolbar”, click “Done”

Actually you don’t have to change any icon, the problem happens when the customize window opens, before you customize them.

Below is an animated gif of the procedure:

icons-bug

Thanks for the great animation. I’m testing this on macOS 10.15.3 (19D49f) using the same toolbar arrangement as you, and approximately the same window layout, but I’m not seeing anything unusual happen when I open the toolbar customization sheet or click Done.

Does the problem still occur if you reboot your Mac in safe mode?

I rebooted using shift, in safe mode, did the same procedure, and got the same results: icons getting bigger and bigger…

Then I tried to modify one thing: disabled “small icons” and the bug disappeared.

Then I enabled again “small icons” and the bug returned, so there is another important thing I did not know, that is necessary to be using “small icons”.


I reboot in normal mode, disabled small icons, the bug does no happen.
Enabled “small icons” and the bug returns, and they get bigger and bigger.


Conclusion: Only happen if using “small icons”, and happens either in Safe Mode or in Normal mode.

I am posting a picture of the icons arrangement, as per your reply I think it may be relevant, so the picture below is in full detail about the icons arrangement.

Please check to use “small icons” on your test machine.

Thank you again, for your full support attention and quick replies. If you need any other kind of information, logs, etc, please ask and I will provide whatever you need to reproduce it.

Thanks. I was able to reproduce the problem on macOS 10.15.3 (19D49f) (but not on macOS 10.14.6) when using small icons.

I guess it should be easy for you to work around the issue by quitting and relaunching EagleFiler if the buttons get too large. Meanwhile, I will try to figure out whether this is an EagleFiler or macOS bug and find a solution.

Glad to know you can reproduce it!

For me its a minor problem, because after quitting and relaunching it stays all right, and I will not be editing the toolbar all the time :slight_smile:

It is all right for me to continuing learning EagleFiler and doing the trial, and my expectation is to buy a license of it, since it seems to do the job I wanted.

Thank you.