C-Command Software Forum

Bug Report: Encrypted volume won't unmount unless app is quit first

Hi, for the 1st time I today created an encrypted volume, put a pdf in it, and set the app to remember my password. Then, a few hours later I opened the app, chose the the volume from File>Open Recent, and when the window opened I selected the pdf and did Quick View it by tapping the space-bar.

So far, so good.

I Hit Cancel to eliminate the Quick View window and Quick View closed. Then I went to File> Close & Lock [file] and I got this error:

http://d.pr/i/m8vPYU

The EagleFiler window for that volume closed out, but the sparsebundle remained on my desktop. I selected the sparsebundle icon and tried to eject it but I got this error, saying EagleFiler was using it, and suggested quitting the app:

http://d.pr/i/Ugb6Tl

I quit EagleFiler (which I didn’t want to do), and then in the Finder I was able to unmount the sparsebundle.

Shouldn’t the volume close/lock the way I did it?

Yes, unfortunately I have seen some cases where OS code keeps the files in use even though EagleFiler itself is no longer using them, and this can prevent the volume from being ejected. If you can find a series of steps that reliably reproduces this problem, please let me know and I will investigate to make sure that it’s not EagleFiler that’s holding onto the files.

If I open the volume but do not interact with the contents then File> Close & Lock [encrypted file] works as expected. But the error is reproducible (only one file in the volume: a 50Mb pdf) if I interact with the pdf in any way

  1. Either

(a) open EagleFiler then File> Open Recent >[encrypted file], or
(b) Spotlight search for [encrypted file], or
© Apple Menu> Recent Items > [encrypted file]

  1. select [encrypted file] - I discovered I don’t even have to Quick Look the file, I found I merely have to select it.

  2. File> Close & Lock [encrypted file]

  3. Error: http://d.pr/i/m8vPYU

Thanks for this information. Which versions of macOS and EagleFiler are you using?

EagleFiler 1.8.1
MacOS Sierra 10.12.6
Stock 3.8GHz 27" 2017 iMac

Thanks. I have not been able to reproduce this issue using those versions and following the steps above. Are you doing anything else before clicking Close & Lock? Does the problem occur if you boot your Mac in safe mode? Does it happen with other PDF files, e.g. this one?

Also, if you send me an e-mail I can get you a test build of EagleFiler to try debug this.

Not doing anything else. Just booted into safe mode for the first time on this newish iMac (boy, does that slow down everything!) and the problem remained.

In Safe Mode downloaded the pdf file to my desktop, opened EagleFiler again, created encrypted sparsebundle to desktop, drag/dropped pdf into test library, then closed/locked it. Then I double-clicked on the sparsebundle and EagleFiler crashed. I then created a Diagnostic Report (Dropbox).

Relaunched EagleFiler (still in Safe Mode) and did Open Recent > Test Library. Pop-up asked for my password, Sparsebundle opened and I was able to select and Quick Look the file, and then I was able to Close&Lock the file without problem!!!

Quit app. Clicked on sparsebundle and chose ‘Open In’ > ‘Other’ > EagleFiler and EagleFiler launched but gave me the pop-up warning that "No Library Is Open’

I’ll send you an email in a few minutes, after I restart normally.

Just restarted normally. EagleFiler did not remember my original problematic encrypted file in File >Open Recent - I had to double-click and unlock the sparsebundle manually, then double-click on the eflibrary inside it to get it to open in EF.

I then tried to select/deselect the file then close&lock it and I got the same exact error as at the beginning of this thread. (However EF now remembered the file, so when I quit/relaunched the app I was able to see and open it in File > Open Recent.

Sending email now.

Next time, please submit the crash log when the EagleFiler Crash Reporter window comes up.

That command tells EagleFiler to import the file, not to mount the disk image and open the library. So that’s why it told you there was no library to import into.

Sorry about that. Open Recent is handled by macOS, not EagleFiler. However, there are other ways to have EagleFiler remember libraries.

It didn’t come up!

Open Recent is handled by macOS, not EagleFiler. However, there are other ways to have EagleFiler remember libraries.

Awesome.

Then maybe what you saw wasn’t a crash, after all. Could you explain in more detail what happened? Also, if there was a crash, this page will show you where to find the crash log file.

I double clicked the sparsebundle in the Finder and EagleFiler disappeared from all windows/spaces and the dock. I just followed your instructions and found two crash logs dated today:

mdworker_2017-12-29-093850_iMac.crash

and

mdworker_2017-12-29-093850-1_iMac.crash

I copied them to my downloads folder and zip archived them, and will send them to you now.

Thanks for sending the crash logs, however these are from the mdworker process, which is part of Spotlight (a third-party EPUB importer plug-in at /Library/Spotlight/epub.mdimporter). It’s not related to EagleFiler.

I’m not sure why double-clicking the sparsebundle made EagleFiler disappear. Double-clicking the file doesn’t even tell EagleFiler to do anything; it just makes the Finder mount it. However, if there are no EagleFiler crash log files, evidently it did not crash.

EagleFiler 1.8.2 works around a PDF Kit bug that may have been the reason ejecting an encrypted library sometimes didn’t work.