C-Command Software Forum

Bug report: pasting text

Create New RTF, paste text (plain or rich) into the Record Viewer. This generates an error: “Error Saving Changes”, and the text is not saved. Paste the same text into the New RTF opened as a new window, and saving is successful.

(v.1.3)

I’m not seeing that problem here. What are you entering in the File column? What text are you pasting? Is there any additional information in the log?

/Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

I pasted: MSTF 934D. IT does not matter what you paste; all fails.
File columns is automatically populated with “Text.rtf”

Console output:
===== Tuesday, March 18, 2008 2:21:56 PM US/Eastern =====
2008-03-18 14:22:04,056 - appcontroller.pyc:132 NSString+MJT.m:1722 -mjtReplaceWithPath:: Assertion Failed: Path ‘/Users/Previous/Documents/Eaglefiler ∆í/Archived email/Archived email.eflibrary/Temporary Items.noindex/EagleFiler-0yyaNY/6/text.rtf’ doesn’t exist.
2008-03-18 14:22:04,073 - records.pyc:1368 Error saving to: /Users/Previous/Documents/Eaglefiler ƒ/Archived email/Files/Text.rtf
Traceback (most recent call last):
File “wash/records.pyc”, line 1366, in setAttributedString
error: MJTAssertionFailedException - Path ‘/Users/Previous/Documents/Eaglefiler \u2206\355/Archived email/Archived email.eflibrary/Temporary Items.noindex/EagleFiler-0yyaNY/6/text.rtf’ doesn’t exist. at NSString+MJT.m:1722 -mjtReplaceWithPath:

I was able to find the problem—thanks. You can avoid this error by removing the “ƒ” from your folder name. I’ll fix the underlying bug in EagleFiler 1.3.1.

This bug in the editor (which applied to files whose paths contained non-ASCII characters) is fixed in EagleFiler 1.3.1.

I get the same error in 1.3.1.

Any time I attempt to create a new file using the “New RTF” button, I get a message that “EagleFiler was unable to save the file to disk” and file content is lost.

I’ve tried saving the file to different folders and to Records, but the new file is not saved.

  • lenspixels

Please send me your log file:

/Users/<username>/Library/Logs/EagleFiler/EagleFiler.log

It looks like you’re seeing a different problem, which is that EagleFiler cannot replace an old RTF file with a new one when the files are stored on a volume that uses a non-Mac filesystem. I think this bug was introduced in EagleFiler 1.3. I’ll fix it in 1.3.2.

This is fixed in EagleFiler 1.3.2.