C-Command Software Forum

Bug: undo add tag

Ran across this bug when I was trying out EagleFiler.

Second time I write this since the forum was nice enough to kick me out (and reset my password?!) when I tried to submit it, trashing everything I had written.

Description: Undoing the adding of a tag results in an exception.

Steps to reproduce using EagleFiler 1.1.2:

  1. Create a new library.
  2. Create a new rich text file (or add whatever).
  3. Click the tags-bar and write “asdf,”.
  4. Hitting command-Z gives “(IndexError: NSRangeException - *** -[NSBigMutableString substringWithRange:]: Range or index out of bounds)”.

“Continue” works most of the time, but the first time I managed to get it stuck in a loop where it said that it would exit, but hitting “Quit” just brought up the same dialog again.

By the way, are there any shortcuts to go to the tags-bar, or to change a title (click-waaaaaiiiit-click takes too long for me)?

Oh well, back to trying out the various information organizers.

Thanks for the report. It looks like this is caused by a Cocoa bug. I’ve worked around it for the next version of EagleFiler.

You can use Command-Shift-T (a.k.a. Record > Tag to go to the tags bar). There isn’t currently a shortcut to edit the title, although you can edit the filename by pressing Enter, and this will often change the title, too, since for many records they are the same.

Great!

Whoops, sorry I missed that obvious shortcut. Regarding title changes, I’m mainly working with PDF-files, where title and filename can differ, so I’ll keep my fingers crossed for a shortcut for title changes (shift-enter/return maybe?).

Here’s another bug (unrelated to the one above, but I don’t want to clutter the forum).

  1. Add “Highlight” to the toolbar.
  2. Create a new Rich text note.
  3. Click in the note area, but don’t select anything.
  4. Clicking “Highlight” gives: “(IndexError: NSRangeException - *** -[NSConcreteTextStorage attribute:atIndex:effectiveRange:]: Range or index out of bounds)”.

“Continue” is no good here, clicking in the main view afterwards gives you errors like “(IndexError: NSRangeException - *** NSRunStorage, _NSBlockNumberForIndex(): index (4294967295) beyond array bounds (0))”.

I think I’d lean towards Option-Enter.

Thanks. By the way, Highlight is also in the Format > Font menu; you don’t have to add it to the toolbar.

This is fixed in EagleFiler 1.1.3.