C-Command Software Forum

Cannot Delete "Resources" already in the Bin

I’m running a new M1 Mac Mini and Big Sur 11.1…
All previous files were transferred from my older Intel Mac Mini when the new M1 was initiated.
My problems first started when Apple Mail refused to accept my Spamsieve version.
I tried many times to clean out all of the old Spamsieve files so that I could “clean install” the latest version compatable with M1 and Big Sur 11.1.
I have managed to delete ALL of the old Spamsieve files on my system and placed them in the Bin, however, when trying to “empty” the Bin I have a “Resources” Folder which refuses to be cleaned out… I have tried to modify the permissions and although the enclosing Folder accepts the new permission the files within that folder do not…
I have a screenshot that would explain the suituation better but cannot find a way of attaching it here…

Why is it is so difficult to get rid of unwanted files, I find this pretty intrusive ?
Can anyone help ?
Thanks,
Ron.

Could you explain more about what that means? Did it report an error message? Which version of SpamSieve were you using?

It shouldn’t be necessary (nor would it help) to clean out any app files, only (possibly) Mail’s private plug-ins folder.

You can drag and drop it into the post you’re writing or click the upload button: Screen Shot 2021-01-21 at 1.09.02 PM

The SpamSieve app files should all have regular permissions so they can be deleted normally. However, macOS will not let you delete an app that’s currently running. It’s also possible that some other software changed the file permissions or ownership.

Thank you.
All is now rectified by temporarily disabling Apple’s System Integrity Protection.
The Trash Bin was then successfully emptied…

1 Like