C-Command Software Forum

Cannot import iWork Pages documents

Cannot import iWork Pages documents. A blank sheet icon appears with filename “-1” in the library.

I guess that is because a Pages document is some kind of fancy folder/package since the size does not show in Finder?

Sorry, there’s a bug in EagleFiler that makes importing packages from the Finder via the capture key not work. It should work if you import them via drag and drop, however.

Thanks, I’ll try it!

No, dragging appears to do nothing but there is an error report.

Adding via File Menu/Import File produce error box
“Could Not Add to Library
error: TaskFailedException - ditto: /Users/richardparkin/Documents/Rix EF library 01/Files/2005-02-21 Minutes.pages: Invalid argument”

Does this happen with the beta that I sent you? Have you tried importing any other Pages files?

It is working with drag and drop with both the original file that I tried and several others.

Must have been a glitch on my machine – I repaired permissions, re-booted and then it worked. Sorry I did not try that first!

This is fixed in EagleFiler 1.1.3.

Thanks! It works for me.