C-Command Software Forum

Cannot install nor de-install SpamSieve

HI, I have been a longtime user of SS. Last month I upgraded to Big Sur on an iMac and a MacBook Pro, and SpamSieve ran just fine. Two weeks later, I reformatted their drives, did a clean install of Big Sur (11.0.1) and reinstalled all apps, including SS. On the iMac, SS installed just fine, but am experiencing problems with the MacBook Pro.

I have downloaded a fresh copy of SS from your website, installed it, and installed the Apple Mail plug-in. I have gone into System Preferences … Privacy and have enabled Full Disk Access, Contacts and Automation for SS. I have gone into the Apple Mail and enabled the plug-in, the following happens:

  1. I get a dialog box asking if I want to allow SS.bundle to access any files? and I click on the Allow Access button.
  2. I then click on the “Apply and Restart Mail” button, I get an error message: Incompatible Plug-ins Disabled.

I then quit Mail (which also quit SS naturally). Whenever I subsequently launch mail (which also automatically launches SS), I get the same error message: Incompatible Plug-ins Disabled. I try to renable the plug-in, but always get the Plug-in Disabled error.

I have tried to Uninstall the Apple Mail plug-in from SS and get the message that it is successfully uninstalled. I quit SS and Mail, and then launch Mail again - and for the first and ONLY time after I run the Uninstall plug-in command, Mail launches fine without any complaint and Mail’s Prefs do not show the SS plugin. BUT, after I quit Mail and relaunch it a 2nd time (and all subsequent time), I am back to getting the “Plug-ins Disabled” message.

I. have tried uninstalling SS - both by moving the app to the Trash as well as using AppCleaner (which removes all/most prefs and support files). Even after uninstalling, when I launch Apple Mail, I get the “Plug-ins Disabled” message.

I have installed and de-installed SS many times and cannot get Apple Mail to launch without giving me the “Plug-ins Disabled” message.

Idea?


Oops, meant to attach these screenshots to the previous post.

Never mind - solved the problem - I think!

I rebooted into macOS Recovery, disabled System Integrity Protection, rebooted, deinstalled SpamSieve - Mail ran fine with no (plug-in) errors. Rebooted, re-enabled SIP, rebooted - Mail ran fine, no sign of the plug-in in the Mail Prefs. Quit Mail and relaunched - several times. Problem is gone.

Not sure what caused the original problem. Shortly after my clean install of Big Sur, I had disabled SIP, rebooted, and did a few things; perhaps I installed SpamSieve at that time. Subsequently I enabled SIP. And sometime after that, who knows how long, Mail started telling me the SS plug-in was incompatible. So, its possible SIP was involved somehow - just a conjecture.

1 Like