C-Command Software Forum

Can't create subfolder

I think this may have to do with a lost or damaged file, but suddenly I can’t create a subfolder in one of my main project folders. (I can do so elsewhere, even in the same Eaglefiler library.) When I try to create a subfolder there, it gets created as a “first level” folder, not a subfolder. (I.e., it’s not nested.) I can then move that folder into the project folder, but while it is visible I can’t move items into it.

At one point I got an “unexpected error message,” but I’m not getting that now, just getting the malfunction.

I’ve tried restarting Eaglefiler and also rebooting.

Never mind
I created a new folder to replace my old project file, moved all the subfolders into it, and deleted the original folder (then renamed back to the original name). That seems to work.

Spoke too soon
I seem to have created a bunch of problems for myself. Records of the file (i.e., the folder contents, including a dozen subfolders) exist in Eaglefiler, but I get the message that the files are missing. The files still exist in my Finder, though (they’re not gone). So I tried re-importing through the Import to EF folder and get the message that they can’t be imported.

How can I basically start over with this folder? I’d like to delete whatever confused info Eaglefiler now has about it and re-import things freshly.

I’ve pulled the files out (not using Eaglefiler) onto a desktop folder called “Rescued files.” I don’t mind losing the subfolder information. (Which Eaglefiler still has, theoretically, but which I gave up on when I pulled the files out.)

It sounds like the original problem may have been due to bad permissions on your drive.

At this point, it’s probably easiest to create a new library and import the contents of the old one by dragging from the Finder.

I stopped short of that but things seem to be working. If problems recur I’ll delete the library.