C-Command Software Forum

can't enable Spamsieve plugin in Mail

After updating to Mojave 10.14, I wan unable activate the Spamsieve plugin as the Enable Mail Plugin tab was not visible in Preferences-General. I deleted Spansieve and did a fresh install but have the same problem. Spamsieve has be given all the necessary privileges in the Security preference pane. Any ideas on how to fix this problem. Thank you.

It’s not a separate tab; there should be a “Manage Plug–ins…” button at the bottom of the window. Please choose “Install Apple Mail Plug-In” from the SpamSieve menu. If you still don’t see the button, please send in a diagnostic report.

Thanks for sending the report. It appears that you are missing the folder where your Mail preferences file is supposed to be stored. This is preventing SpamSieve from saving the preference that tells Mail to look for plug-ins, and I also see other errors in the log about Mail not being able to save its own preferences because the file doesn’t exist.

To try to fix this, please open the Terminal application in your Application/Utilities folder, enter this command (all on one line):

mkdir -p ~/Library/Containers/com.apple.mail/Data/Library/Preferences/

and press Return.

Then choose “Install Apple Mail Plug-In” from the SpamSieve menu.

With SpamSieve 2.9.34 (in public beta) SpamSieve should repair Mail’s preferences for you automatically.

Michael,
I ran the terminal command and for some reason that didn’t work. However, I moved the Preferences folder from my backup to my current drive, uninstalled and reinstalled the Spamsieve plug-in, and went to Mail-Preferences-General. The Manage Plug-ins button was now visible and I enabled the plug-in. Spamsieve now appears to be working properly. Thank you so much for your help. Robert Lasher