C-Command Software Forum

Can't move spam messages to Google "Spam"-folder on server

Hi all,

I’ve followed the guide on how to get the Spam e-mails into a server mailbox. BUT when I get a spam mail or train as spam, Apple mail creates an Local Mailbox called “Spam” instead of moving the e-mail to the google “Spam” mailbox.
The “Spam” mailbox is visible on my Gmail and used in the “SpamSieve” rule. The appropriate scripts has been run through “SpamSieve - Change Settings”…

I can get around it by creating a new Gmail mailbox named anything but “Spam”.

I’ve ran this setup with the Gmail Spam mailbox before I formatted my mac with no issues at all.

Any Ideas on how to get the spam messages into the Gmail “Spam” mailbox?

Best regards
Ole

Yosemite 10.10.3, Apple Mail 8.2

When you use “Change Settings” to tell SpamSieve to use a spam mailbox on the server, it looks for the mailbox at the top level. Is your Spam mailbox right under your Gmail account, or inside a [Gmail] folder? If the latter, you would need to set an IMAP path prefix in Mail’s account preferences.

The Spam mailbox is at the top level as far as I can tell.

Mailbox level.jpg

At this point (after many attempts) I have created a “SpamSpam” mailbox which works just fine - just like expected. Still, to use the Google spam folder would be preferable.

/Ole

Yes, that looks right. You can use the List Mailboxes script to see what internal names Mail is using/expecting.

Interesting. No “Spam” mailbox shows up after running the script… Well, I guess that does explain the root of the issue without solving it.

Google
Pers. Mailboxes
>>My personal subfolders<<
SpamSpam
INBOX
iCloud

/Ole

Maybe try deleting the Spam mailbox in Mail and recreating it.

As it is Gmails native spam mailbox it is not an option to delete it. I have tried several times to uncheck to mailbox in as an IMAP mailbox and checked it again - with no luck though.

At this point ill stick to the “SpamSpam” option, make the native Spam mailbox not appear in IMAP and tell Apple mail to use SpamSpam as my junk mailbox.

The native google Spam mailbox remains a mystery in my case. Thanks a lot for the suggestions though!

/Ole

OK. I wasn’t sure that was the native Gmail Spam mailbox because normally that appears in Mail’s special Junk mailbox. It might help to set another mailbox as the Junk mailbox using “Use This Mailbox As”.

That would work as well.