C-Command Software Forum

Check for Update: NSURLErrorDomain error -1004

When I got the email announcing 2.9.7, I tried using ‘check now’ from the previous version, but got this error.

I manually updated to 2.9.7, but the error persists.

Googling gets me some reference to a MUCH earlier version and Internet misconfiguration, but this does not seem to apply here. I am using OS X 10.8.3 and Mac Mail client.

That error means “cannot connect to host” (i.e. c-command.com). Are you using a network blocker such as Little Snitch?

I do use Little Snitch, but I don’t see any rules that would block SpamSieve.

Can you give me process, host, port and protocol details please?

Process: SpamSieve
Host: c-command.com (a.k.a. dreamhost.com)
Port: 80
Protocol: HTTP

Michael

I have checked again, and there’s nothing blocking SpamSieve.

I have tried new rules explicitly permitting access via HTTP port 80 to c-command.com and dreamhost.com but the problem persists.

It’s not a big deal - I can still upgrade manually - but I am happy to help diagnose further if you wish.

-Bernard

Could you try clicking Stop for the Network Filter in Little Snitch’s preferences, to be sure that it isn’t blocking anything?

Secondly, please try clicking this link to see whether you can access the versions file from outside of SpamSieve.

Stopping the network filter makes no difference, but I CAN access the versions file from the same mac.

What about if you reboot your Mac in safe mode?

Initially I had a problem booting into safe mode - hence the delay in replying. I have fixed that problem, but now I am in safe mode the problem persists.

Thanks for checking. Please contact me via e-mail, and I’ll send you a new version of SpamSieve to try to figure out why this isn’t working on your Mac.

I just found the answer - just as you replied.

After all the other tests, I looked at network settings and tried simply using Google’s DNS (8.8.8.8 / 8.8.4.4) instead of my ISP’s and that fixed the problem!

Ah well, I could have been in the sun but I spent the day with my Mac instead!

Thanks for your help - and sorry it was a “wild goose chase”.

Thanks for the follow-up.