C-Command Software Forum

Choose Library for PDF to EagleFiler Service

I use the Save PDF to EagleFiler Service a lot, but I run into one problem with it. I have several different libraries, and the only way I can see currently to make sure it saves to the right library is to go to EagleFiler first and make sure the library I want is frontmost.

I would love to have a way to specify which library I want the file saved to. Since it’s now possible to roll our own services, I’m guessing there’s a way to do this with AppleScript and/or Automator. Any suggestions? I use Firefox as my web browser.

kabing

You could save a script like this as an application in the PDF Services folder:

on open _files
    tell application "EagleFiler"
        tell library document "EagleFilerTest.eflibrary"
            import files _files
        end tell
    end tell
end open

Thanks!

If someone else wants to do this later, the PDF Services folder is can be found in ~/Library. (~ represents your home folder.)

It had become clear that EagleFiler was definitely the way I wanted to go, so I bought my license today. Thanks for such a great product and such good customer service.

Did this, but get the following error,

"Can’t get <<class LibD>> “EagleFilerTest.eflibrary” of application “EagleFiler”.

You need to replace EagleFilerTest with the name of the library that you want the script to import into. Also, that library must be open. If you want the script to open the library, you could change the script to something like:

on open _files
    tell application "EagleFiler"
        open "/Users/mjt/Desktop/EagleFilerTest/EagleFilerTest.eflibrary"
        repeat until exists library document "EagleFilerTest.eflibrary"
            delay 0.5
        end repeat
        tell library document "EagleFilerTest.eflibrary"
            import files _files
        end tell
    end tell
end open

I’d like to adapt this script to add the new “asking for options” argument, but I don’t appear to have the syntax right, as I get error messages when I try to compile the script. I’d appreciate some help, when you have the time.

You could change the line:

import files _files

to:

import files _files with asking for options

Another option, instead of using a script, would be to hold down the Option key when choosing “Save PDF to EagleFiler.”

Thanks! I was missing the “with” before.

I will keep in mind the option-key, too. In experimenting, I have found I have to make sure I hold it down until the dialog appears, or it imports without asking for options.