Clicking menubar menu brings SpamSieve to foreground, disables menu items

MacOS 14.5, SpamSieve 3.05, Apple Mail. Clicking the SpamSieve menu in the menubar brings SpamSieve to the foreground, disabling the Train as Good, Train as Spam and Filter Messages items. Keyboard commands appear to work correctly. Is there a setting that I’ve missed that keeps SpamSieve in the background and allows these menu items to be used?

To train SpamSieve from Apple Mail or Outlook you should use the menu commands in the SpamSieve menu bar icon or in the Dock menu:

There’s more information about this in the Train as Good/Spam section of the manual.

I understand how to train. With regards, I’ve been using SpamSieve successfully for many years. I am using SpamSieve v 3.05 on a MacBook , macOS 14.5 without incident. The current problem is that, on a Mac min running macOS 14.5, when the SpamSieve’s menubar icon is clicked, SpamSieve is brought to the foreground and the relevant menu items are disabled. My understanding is that for the menu items to be enabled, Apple Mail must be in the foreground. This is not possible with the behavior I’m describing. I don’t know whether this is a SpamSieve issue or a macOS issue or a user issue, but I am at a loss to correct it.

If you click the SpamSieve menu bar icon at the top of the screen (shown in the left screenshot above) it will open the menu, not bring SpamSieve to the foreground. So you can use those menu commands from within Apple Mail.

Similarly, if you click and hold on the SpamSieve Dock icon (the right screenshot above) it will open the menu without switching to SpamSieve. Only clicking (without holding) on the icon will bring SpamSieve to the foreground (which is what you don’t want).

Unless, perhaps, you have some sort of utility installed that changes how clicking in the menu bar works?