C-Command Software Forum

Cmd-Opt-L clash between Apple Mail and EagleFiler?

I often use Cmd-Opt-L in Apple Mail to apply filtering rules to selected messages. Most of them time this works, but sometimes it brings forward, or launches, EagleFiler with an Import dialog. EF does have Cmd-Opt-L as its own shortcut, but it’s not related to import, and should not be triggering if EF is not frontmost.

Anyone else seen this? I’m on Mojave 10.14.6.

The shortcut for EagleFiler’s Quick Look command is not active when you are in another app, and it doesn’t summon the Import dialog. So my guess is that this is related to something that you’ve set up in Mail or globally. Do you have any Mail rules that run AppleScripts?

The import dialog is certainly being summoned by something, almost as if typing Alt-F1, but slightly different (no arrow or icon appears on EagleFiler’s dock icon, for instance).

Mail rules: yes, I guess: I have SpamSieve installed - fresh install a new days ago. I followed the instructions in terms of mail plug-in and rules. Might that be an issue?

If you are doing something that is triggering an import into EagleFiler, if the Option key is down (e.g. as a result of pressing Command-Option-L) EagleFiler will interpret that to mean that you want to see the import options window.

SpamSieve does not tell EagleFiler to do anything. You don’t have a rule that runs the Import From Apple Mail script, for instance?

I still don’t know what’s triggering the import. I’ve checked the mail rules and none of them is trying to run a script. And this problem comes and goes. It’s happening right now, and it still occurs if I uncheck all the rules in Mail.

I wonder if it’s something to do with this? This is in Keyboard->Shortcuts->Services. I’m not sure why the text is in German: I’m in Berlin but this MacBook and its settings should all be UK. I also don’t know what that shortcut denotes. I turned the shortcut off and on again and the problem seems to have gone away again - for now.

Does it occur if you choose Apply Rules from the menu instead of using the keyboard shortcut? Also, you could proceed with the Import alert, let it finish the import, and then see what was imported to get a clue as to where the import originated.

This is the EagleFiler system service for importing the selected text/item. The shortcut for the second one is Command-Shift-Option-1 on a US keyboard. Is the character in the screenshot associated with the letter L on your keyboard?

Choosing Apply Rules from the menu is fine.

Letting it complete, it appears to import the selected mail message as RTF.

So, I turn off that Services short-cut, and the problem goes away. I turn it on again, and the problem doesn’t come back. But I’m guessing it will arise again soon.

I have no idea what that Services short-cut is. It’s not Cmd-Opt-L, which appears as you’d expect. It’s also not Cmd-Shift-1, which also looks as you’d expect. If I do Restore Defaults the odd short-cut comes back again.

If you type Option-L in a TextEdit document, does it show the ¬ symbol? That would explain why it’s activating for Command-Option-L.

The shortcut for EagleFiler: Import With Options is by default set to Command-⁄ where corresponds to Option-Shift-1 on a US keyboard. But perhaps is somehow related to L on your keyboard? Or perhaps it was changed in System Preferences. In any case, you could try changing the shortcut to something else, e.g. Command-Shift-Option-1 and see what it shows for that.

Yep, you’re right: Opt-L is “¬”. I’m not sure why it’s appearing as Cmd-¬ rather than Cmd-Opt-L.

I can only guess that something went rather astray with EagleFiler’s installation when it tried to set up this shortcut… Having the shortcut names in German is odd too. Is any of the installation process using geolocation?

There’s no geolocation, and EagleFiler itself doesn’t install any shortcuts. It just declares which services it provides, and what their names are in different languages, and macOS is supposed to choose what to display. Do you perhaps have the language or region set to Germany in System Preferences ‣ Language & Region?

Nope, that’s set to United Kingdom, as it should be. The only thing German about this machine right now is the geolocation and the timezone. Maybe this is just some bizarre shortcuts bug in Mojave?

That could be. Was this Mac ever previously set to German? It could be that macOS remembered the service names from a previous launch of the app.

Nope - has always been a UK-Language and -Region Mac. I did buy EagleFiler for the first time just a few days ago - never used it before - and I have been in Germany that whole time.