cmnd-ctrl-S producing odd behavior

The cmnd-ctrl-S shortcut to Train as Spam seems to be already taken up by Apple Mail’s Hide/Show Sidebar command, so when I try to take the shortcut to train a message as spam all I get is a toggled sidebar.

Do you have any suggestions about how to fix this?

(This may have something to do with the fact that I somehow managed never to update to Ventura and am still on OS 12.2.1. If so and the answer is “update to Ventura,” I’ll happily go ahead and do that—but maybe I should just skip Ventura and get right to OS 14. But I want to make sure that this won’t be a problem there as well.)

1 Like

SpamSieve registers its shortcut as a global hotkey, so it should override the application-level shortcut in Mail. This is working for me and seemingly almost everyone on all versions of macOS. I’m not sure why you and a few others are seeing otherwise. Does it help if you quit and relaunch Mail? Do you have any other keyboard shortcut utilities installed? The next version of SpamSieve will have more diagnostics built in to troubleshoot this.

1 Like

I’m also having this problem. I reset the Mail command to CTL-OPTION-CMD-S, and so far it seems to be taking.

1 Like

Oh, cool. Would you mind explaining briefly how to do that? I went to System Preferences>Keyboard>Shortcuts but couldn’t find it.

Which keyboard layout are you each using? Does the keyboard shortcut for Train as Good work?

You were almost there: to to System Preferences>Keyboard>Shortcuts > App Shortcuts > and click the plus sign. I also solved this the same way, using a slightly different shortcut

I also had this problem and solved it the same way.

Hmm. I feel like I’m not seeing what I’m supposed to be seeing…this may be just because I’m still using OS 12, in which case I might as well skip 13 and go right to 14. I’m not sure how that happened.

Anyway, this is what I’m seeing—does anybody have any ideas about how I can get specifically to the Mail shortcuts?

It’s the same functionality pre-Ventura, just with a different look. In your case, you can click the + button, then select Mail as the app, and enter the menu item title.

GOT IT! Thank you so much!

Thanks to everyone who reported this issue with the keyboard shortcuts. I think it’s fixed in SpamSieve 3.0.1b1.