C-Command Software Forum

Codesign error again

Hi Michael,

For some reason as of the latest version, I’m back to getting the dialog asking permission to access contacts every time the app launches. I’ve tried the old solution to that with the codesign terminal command, but that hasn’t fixed it. What else should I try?

Please see Repeated Access Prompts.

Thanks Michael. But alas, that hasn’t fixed it. I’ve run the

tccutil reset AddressBook

command in Terminal. The only thing that changed as a result was several other apps also asking permission to access contacts (which makes sense I guess). But SpamSieve has asked again three times since I did that.

It’s getting pretty wearing after a fortnight of this behaviour daily, and a side effect seems to be that SS doesn’t process emails until I give permission to access contacts, with the consequence that I find several false negatives in my inbox.

If you ran codesign yourself, that probably damaged the app, so you would need to install fresh copy.

Right, thanks. That does seem to have fixed it. I thought I had done that earlier; but maybe I needed to do it again after trying the reset addressbook thingy? Anyway, all good now. :slight_smile: